meta-openembedded: subtree update:a2928764c2..19528ba2a6

Adrian Bunk (1):
      libqmi: Replace clang patch with configure option

Bartosz Golaszewski (3):
      yad: new package
      zenity: new package
      unclutter-xfixes: new package

Khem Raj (2):
      mycroft: Remove alsa-oss from rdeps
      bigbuckbunny: Use faster download mirrors

Oleksandr Kravchuk (21):
      capnproto: update to 0.7.0
      ddrescue: update to 1.24
      fmt: update to 6.0.0
      jsonrpc: update to 1.2.0
      libburn: update to 1.5.0
      libdvdread: update to 6.0.1
      libev: update to 4.27
      libmodplug: update to 0.8.9.0
      libnice: update to 0.1.16
      libopus: update to 1.3.1
      libsass: update to 3.6.1
      libuv: update to 1.32.0
      libsocketcan: update to 0.0.11
      tree: update to 1.8.0
      xclock: update to 1.0.9
      xcursorgen: update to 1.0.7
      xfontsel: update to 1.0.6
      xmag: update to 1.0.6
      xmessage: update to 1.0.5
      xorg-sgml-doctools: update to 1.11
      evtest: update to 1.34

Peiran Hong (1):
      tcpdump: Fix CVE-2017-16808

Change-Id: I4f2f575382cd34404d10470ece0aae7620487902
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-extended/ddrescue/ddrescue_1.24.bb b/meta-openembedded/meta-oe/recipes-extended/ddrescue/ddrescue_1.24.bb
new file mode 100644
index 0000000..52bd11b
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-extended/ddrescue/ddrescue_1.24.bb
@@ -0,0 +1,44 @@
+SUMMARY = "Data recovery tool"
+DESCRIPTION = "GNU ddrescue is a data recovery tool. It copies data \
+    from one file or block device (hard disc, cdrom, etc) to another, \
+    trying hard to rescue data in case of read errors."
+HOMEPAGE = "http://www.gnu.org/software/ddrescue/ddrescue.html"
+SECTION = "console"
+LICENSE = "GPLv2+"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \
+                    file://main_common.cc;beginline=5;endline=16;md5=3ec288b2676528cd2b069364e313016f"
+
+SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.lz"
+SRC_URI[md5sum] = "8ac89f833c0df221723e33b447e230fe"
+SRC_URI[sha256sum] = "4b5d3feede70e3657ca6b3c7844f23131851cbb6af0cecc9721500f7d7021087"
+
+# This isn't already added by base.bbclass
+do_unpack[depends] += "lzip-native:do_populate_sysroot"
+
+CONFIGUREOPTS = "\
+    '--srcdir=${S}' \
+    '--prefix=${prefix}' \
+    '--exec-prefix=${exec_prefix}' \
+    '--bindir=${bindir}' \
+    '--datadir=${datadir}' \
+    '--infodir=${infodir}' \
+    '--sysconfdir=${sysconfdir}' \
+    'CXX=${CXX}' \
+    'CPPFLAGS=${CPPFLAGS}' \
+    'CXXFLAGS=${CXXFLAGS}' \
+    'LDFLAGS=${LDFLAGS}' \
+"
+EXTRA_OEMAKE = ""
+
+do_configure () {
+    ${S}/configure ${CONFIGUREOPTS}
+}
+
+do_install () {
+    oe_runmake 'DESTDIR=${D}' install
+    # Info dir listing isn't interesting at this point so remove it if it exists.
+    if [ -e "${D}${infodir}/dir" ]; then
+        rm -f ${D}${infodir}/dir
+    fi
+}