meta-xilinx: subtree update:874b9cee5e..569f52f275

Jaewon Lee (1):
      xilinx-board.inc: Introducing inc file to add BOARD/BOARD_VARIANT

Madhurkiran Harikrishnan (2):
      weston.ini: Do not set hard requirement for input devices
      libmali-xlnx: Update the mali userspace libraries to 2020.2

Mark Hatle (2):
      libmali-xlnx: Fix the package arch
      Various: Packages using libGL may need to be declared SOC_VARIANT_ARCH

Raju Kumar Pothuraju (1):
      versal-generic.conf:zynqmp-generic.conf: Add MACHINE_ESSENTIAL_EXTRA_RDEPENDS variable only for specific machines.

Sai Hari Chandana Kalluri (7):
      Add meta-python2 in bblayers.conf
      xrt_git.bb: Replace deprecated boost macros
      perf: Fix compilation issues Fix perf variable definition and libtraceevent with binutils. The above errors are fixed by including the following patches to the kernel tree: 	0001-libtraceevent-Fix-build-with-binutils-2.35.patch         0001-perf-bench-Share-some-global-variables-to-fix-build-.patch         0001-perf-cs-etm-Move-definition-of-traceid_list-global-v.patch         0001-perf-tests-bp_account-Make-global-variable-static.patch
      opencv_3.4.3: Remove support for opencv 3.4
      Update commit id and branch for components for 2020.2 release
      update XILINX_VER_MAIN to 2020.2
      bootgen: Update commit id for 2020.2 release

Sandeep Gundlupet Raju (1):
      kernel-module-dp: Add support for Xilinx DP drivers

Vishal Sagar (1):
      kernel-module-hdmi: Update commit id and license md5sum for 2020.2

ch vamshi krishna (3):
      updating xrt commit id
      updating final XRT commit id for 2020.2
      updating XRT/Zocl commit id for 2020.2

rbramand (1):
      ] CR-1076958 Put libxrt libs softlinks in the main package

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I4c6b12024c4d07388334e29177417e34fe6dea87
diff --git a/meta-xilinx/meta-xilinx-bsp/recipes-xrt/xrt/xrt_git.bb b/meta-xilinx/meta-xilinx-bsp/recipes-xrt/xrt/xrt_git.bb
index 71725d0..e814f11 100644
--- a/meta-xilinx/meta-xilinx-bsp/recipes-xrt/xrt/xrt_git.bb
+++ b/meta-xilinx/meta-xilinx-bsp/recipes-xrt/xrt/xrt_git.bb
@@ -9,13 +9,15 @@
                     file://runtime_src/core/pcie/tools/xbutil/LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87 \
                     file://runtime_src/core/edge/tools/xbutil/LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87 "
 
-BRANCH ?= "2020.1_PU1"
+BRANCH ?= "2020.2"
 REPO ?= "git://github.com/Xilinx/XRT.git;protocol=https"
 BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
 SRC_URI = "${REPO};${BRANCHARG}"
 
-PV = "202010.2.7.0"
-SRCREV ?= "8a4c6eb5012c57423fba468e1af8df53a293dcd5"
+FILESEXTRAPATHS_prepend := "${THISDIR}/xrt:"
+SRC_URI_append = " file://0001-Replace-boost-detail-endian.hpp-with-boost-predef-ot.patch"
+PV = "202020.2.8.0"
+SRCREV ?= "f19a872233fbfe2eb933f25fa3d9a780ced774e5"
 
 S = "${WORKDIR}/git/src"
 
@@ -38,6 +40,13 @@
 DEPENDS_append_versal-ai-core += " libmetal libxaiengine"
 RDEPENDS_${PN}_append_versal-ai-core += " libxaiengine"
 
+FILES_SOLIBSDEV = ""
+FILES_${PN} += "\
+    ${libdir}/lib*.so \
+    ${libdir}/lib*.so.* \
+    /lib/*.so* "
+INSANE_SKIP_${PN} += "dev-so"
+
 pkg_postinst_ontarget_${PN}() {
   #!/bin/sh
   if [ ! -e /etc/OpenCL/vendors/xilinx.icd ]; then