meta-openembedded: subtree update:679bb49126..7c02c7d411
Adam Miartus (1):
toybox: allow user to provide own defconfig
Adrian Bunk (5):
uftrace: Fix PR
mraa: Replace -fcommon with fix
mozjs: Remove workaround for gcc < 4.9
flatbuffers: Remove workarounds for gcc < 6
protobuf-c: Remove workarounds for gcc < 6
Alejandro Enedino Hernandez Samaniego (2):
weechat: introduce weechat recipe providing a fully working IRC client
imapfilter: introduce imapfilter recipe providing a mailbox filter through the IMAP protocol
Alejandro Hernandez Samaniego (1):
remmina: Upgrade to version 1.4.3
Alexander Vickberg (2):
tcpdump: Fix PACKAGECONFIG for OpenSSL
iperf3: Add OpenSSL build option to PACKAGECONFIG
Alistair Francis (2):
geany-plugins: Support libgit2 version 1.0
libgit2: Update to v1.0.0
Andreas Müller (5):
xfce4-notifyd: upgrade 0.6.0 -> 0.6.1
xfconf: upgrade 4.14.1 -> 4.14.2
xfwm4: upgrade 4.14.1 -> 4.14.2
qpdf: upgrade 9.1.0 -> 10.0.1
qpdf: link libatomic explicitly on mips
Bartłomiej Burdukiewicz (2):
pugixml: generate pkgconfig files.
pugixml: add native and nativesdk BBCLASSEXTEND
Claude Bing (3):
php: fix PACKAGECONFIG for soap
php: fix opcache link error in 7.4
php: update fix for opcache link issue in 7.4.4
Emmanuel Roullit (1):
cockpit: fix metainfo.xml file ownership
Gianfranco Costamagna (1):
cpprest: Disable one more test requiring internet connection
Gregory Vimont (1):
opencv: 4.1.0 -> 4.3.0
Jonathan Liu (1):
x11vnc: fix xfc NULL pointer dereference
Jorge Solla (1):
Cockpit: Added missing dependency on udisks2 for package cockpit-storaged
Khem Raj (7):
remmina: Depend on avahi instead of Avahi-ui
libgit2: Enable pcre2 regexp backend
con2fbmap: Add recipe
xf86-input-void: Drop INC_PR
nodejs: Fix build with icu 67.1
nss: Remove mcpu to avoid march conflicts
pmdk: Update to 1.8
Konrad Weihmann (2):
php: fix zip package config
php: add multibyte string support config
Leon Anavi (1):
lirc: upgrade 0.9.4d -> 0.10.1
Michael Haener (1):
cockpit: Add recipe version 218
Mingli Yu (10):
python3-ntplib: add missing python3-io RDEPENDS
python3-pid: add the missing rdepends
python3-parallax: add the missing rdepends
python3-pkgconfig: add missing rdepends
python3-pathlib2: add the missing rdepends
python3-ptyprocess: add the missing rdepends
python3-pydbus: add the missing rdepends
python3-pyudev: add the missing rdepends
python3-zipp: add the missing rdepends
gnome-themes-extra: correct the recipe name
Pierre-Jean Texier (1):
ccid: upgrade 1.4.31 -> 1.4.32
Rasmus Villemoes (1):
libgpiod: split c++ library to its own package
Sean Nyekjaer (1):
gpsd: Upgrade 3.19 -> 3.20
Slater, Joseph (2):
python-pretty-table: add rdep's
python3-pyhamcrest: add rdep
Trevor Gamblin (7):
python3-py: add python3-netclient to RDEPENDS
python3-markdown: add logging and setuptools to RDEPENDS
python3-pyrsistent: add python3-numbers to RDEPENDS
python3-pytoml: add datetime and stringold to RDEPENDS
python3-dbusmock: re-add recipe and fix patch path
python3-pyyaml: add python3-netclient to RDEPENDS
python3-werkzeug: add python3-logging to RDEPENDS
Wang Mingyu (6):
mailcap: upgrade 2.1.48 -> 2.1.49
sanlock: upgrade 3.8.0 -> 3.8.1
libcgi-perl: upgrade 4.46 -> 4.47
libencode-perl: upgrade 3.05 -> 3.06
python3-idna: upgrade 2.8 -> 2.9
multipath-tools: upgrade 0.8.3 -> 0.8.4
Yi Zhao (1):
nginx: remove /var/log/nginx when do_install
Zang Ruochen (8):
python3-parse-type: Modify ptest output format
python3-pluggy: Modify ptest output format
python3-polyline: Modify ptest output format
python3-precise-runner: Modify ptest output format
python3-prettytable: Modify ptest output format
python3-ptyprocess: Modify ptest output format
python3-pyasn1: Modify ptest output format
python3-pyasn1-modules: Modify ptest output format
Zheng Ruoqin (4):
python3-pyserial: Modify ptest output format
python3-pyroute2: Modify ptest output format
v4l-utils: upgrade 1.18.0 -> 1.18.1
cpprest: upgrade 2.10.15 -> 2.10.16
Zong Li (1):
Upgrade testfloat to 3e version.
niko.mauno@vaisala.com (3):
python3-setuptools-scm: Cosmetic improvement
python3-setuptools-scm: Add nativesdk to BBCLASSEXTEND
python3-attrs: Add nativesdk to BBCLASSEXTEND
Change-Id: I696f29557eafda5f9f9d6e26525e1a5819982a4b
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-openembedded/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.18.1.bb b/meta-openembedded/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.18.1.bb
new file mode 100644
index 0000000..193335d
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-multimedia/v4l2apps/v4l-utils_1.18.1.bb
@@ -0,0 +1,56 @@
+SUMMARY = "v4l2 and IR applications"
+LICENSE = "GPLv2 & LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=48da9957849056017dc568bbc43d8975 \
+ file://COPYING.libv4l;md5=d749e86a105281d7a44c2328acebc4b0"
+PROVIDES = "libv4l media-ctl"
+
+DEPENDS = "jpeg \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', '', d)}"
+DEPENDS_append_libc-musl = " argp-standalone"
+DEPENDS_append_class-target = " udev"
+LDFLAGS_append = " -pthread"
+
+inherit autotools gettext pkgconfig
+
+PACKAGECONFIG ??= "media-ctl"
+PACKAGECONFIG[media-ctl] = "--enable-v4l-utils,--disable-v4l-utils,,"
+
+SRC_URI = "http://linuxtv.org/downloads/v4l-utils/v4l-utils-${PV}.tar.bz2 \
+ file://0001-Revert-media-ctl-Don-t-install-libmediactl-and-libv4.patch \
+ file://mediactl-pkgconfig.patch \
+ file://export-mediactl-headers.patch \
+ file://0002-contrib-test-Link-mc_nextgen_test-with-libargp-if-ne.patch \
+ file://0005-Define-error_t-and-include-sys-types.h.patch \
+ file://0006-Fix-build-on-32bit-arches-with-64bit-time_t.patch \
+ file://0007-Do-not-use-getsubopt.patch \
+ "
+SRC_URI[md5sum] = "ff2dd75970683be9a301ed949b3372b3"
+SRC_URI[sha256sum] = "25fc42253722401f8742f04dc50a444dfa9b75378e7d09b55035bcbb44c5f342"
+
+EXTRA_OECONF = "--disable-qv4l2 --enable-shared --with-udevdir=${base_libdir}/udev"
+
+VIRTUAL-RUNTIME_ir-keytable-keymaps ?= "rc-keymaps"
+
+PACKAGES =+ "media-ctl ir-keytable rc-keymaps libv4l libv4l-dev"
+
+RPROVIDES_${PN}-dbg += "libv4l-dbg"
+
+FILES_media-ctl = "${bindir}/media-ctl ${libdir}/libmediactl.so.*"
+
+FILES_ir-keytable = "${bindir}/ir-keytable ${base_libdir}/udev/rules.d/*-infrared.rules"
+RDEPENDS_ir-keytable += "${VIRTUAL-RUNTIME_ir-keytable-keymaps}"
+
+FILES_rc-keymaps = "${sysconfdir}/rc* ${base_libdir}/udev/rc*"
+
+FILES_${PN} = "${bindir} ${sbindir}"
+
+FILES_libv4l += "${libdir}/libv4l*${SOLIBS} ${libdir}/libv4l/*.so ${libdir}/libv4l/plugins/*.so \
+ ${libdir}/libdvbv5*${SOLIBS} \
+ ${libdir}/libv4l/*-decomp"
+
+FILES_libv4l-dev += "${includedir} ${libdir}/pkgconfig \
+ ${libdir}/libv4l*${SOLIBSDEV} ${libdir}/*.la \
+ ${libdir}/v4l*${SOLIBSDEV} ${libdir}/libv4l/*.la ${libdir}/libv4l/plugins/*.la"
+
+PARALLEL_MAKE_class-native = ""
+BBCLASSEXTEND = "native"