meta-openembedded: subtree update:679bb49126..7c02c7d411
Adam Miartus (1):
toybox: allow user to provide own defconfig
Adrian Bunk (5):
uftrace: Fix PR
mraa: Replace -fcommon with fix
mozjs: Remove workaround for gcc < 4.9
flatbuffers: Remove workarounds for gcc < 6
protobuf-c: Remove workarounds for gcc < 6
Alejandro Enedino Hernandez Samaniego (2):
weechat: introduce weechat recipe providing a fully working IRC client
imapfilter: introduce imapfilter recipe providing a mailbox filter through the IMAP protocol
Alejandro Hernandez Samaniego (1):
remmina: Upgrade to version 1.4.3
Alexander Vickberg (2):
tcpdump: Fix PACKAGECONFIG for OpenSSL
iperf3: Add OpenSSL build option to PACKAGECONFIG
Alistair Francis (2):
geany-plugins: Support libgit2 version 1.0
libgit2: Update to v1.0.0
Andreas Müller (5):
xfce4-notifyd: upgrade 0.6.0 -> 0.6.1
xfconf: upgrade 4.14.1 -> 4.14.2
xfwm4: upgrade 4.14.1 -> 4.14.2
qpdf: upgrade 9.1.0 -> 10.0.1
qpdf: link libatomic explicitly on mips
Bartłomiej Burdukiewicz (2):
pugixml: generate pkgconfig files.
pugixml: add native and nativesdk BBCLASSEXTEND
Claude Bing (3):
php: fix PACKAGECONFIG for soap
php: fix opcache link error in 7.4
php: update fix for opcache link issue in 7.4.4
Emmanuel Roullit (1):
cockpit: fix metainfo.xml file ownership
Gianfranco Costamagna (1):
cpprest: Disable one more test requiring internet connection
Gregory Vimont (1):
opencv: 4.1.0 -> 4.3.0
Jonathan Liu (1):
x11vnc: fix xfc NULL pointer dereference
Jorge Solla (1):
Cockpit: Added missing dependency on udisks2 for package cockpit-storaged
Khem Raj (7):
remmina: Depend on avahi instead of Avahi-ui
libgit2: Enable pcre2 regexp backend
con2fbmap: Add recipe
xf86-input-void: Drop INC_PR
nodejs: Fix build with icu 67.1
nss: Remove mcpu to avoid march conflicts
pmdk: Update to 1.8
Konrad Weihmann (2):
php: fix zip package config
php: add multibyte string support config
Leon Anavi (1):
lirc: upgrade 0.9.4d -> 0.10.1
Michael Haener (1):
cockpit: Add recipe version 218
Mingli Yu (10):
python3-ntplib: add missing python3-io RDEPENDS
python3-pid: add the missing rdepends
python3-parallax: add the missing rdepends
python3-pkgconfig: add missing rdepends
python3-pathlib2: add the missing rdepends
python3-ptyprocess: add the missing rdepends
python3-pydbus: add the missing rdepends
python3-pyudev: add the missing rdepends
python3-zipp: add the missing rdepends
gnome-themes-extra: correct the recipe name
Pierre-Jean Texier (1):
ccid: upgrade 1.4.31 -> 1.4.32
Rasmus Villemoes (1):
libgpiod: split c++ library to its own package
Sean Nyekjaer (1):
gpsd: Upgrade 3.19 -> 3.20
Slater, Joseph (2):
python-pretty-table: add rdep's
python3-pyhamcrest: add rdep
Trevor Gamblin (7):
python3-py: add python3-netclient to RDEPENDS
python3-markdown: add logging and setuptools to RDEPENDS
python3-pyrsistent: add python3-numbers to RDEPENDS
python3-pytoml: add datetime and stringold to RDEPENDS
python3-dbusmock: re-add recipe and fix patch path
python3-pyyaml: add python3-netclient to RDEPENDS
python3-werkzeug: add python3-logging to RDEPENDS
Wang Mingyu (6):
mailcap: upgrade 2.1.48 -> 2.1.49
sanlock: upgrade 3.8.0 -> 3.8.1
libcgi-perl: upgrade 4.46 -> 4.47
libencode-perl: upgrade 3.05 -> 3.06
python3-idna: upgrade 2.8 -> 2.9
multipath-tools: upgrade 0.8.3 -> 0.8.4
Yi Zhao (1):
nginx: remove /var/log/nginx when do_install
Zang Ruochen (8):
python3-parse-type: Modify ptest output format
python3-pluggy: Modify ptest output format
python3-polyline: Modify ptest output format
python3-precise-runner: Modify ptest output format
python3-prettytable: Modify ptest output format
python3-ptyprocess: Modify ptest output format
python3-pyasn1: Modify ptest output format
python3-pyasn1-modules: Modify ptest output format
Zheng Ruoqin (4):
python3-pyserial: Modify ptest output format
python3-pyroute2: Modify ptest output format
v4l-utils: upgrade 1.18.0 -> 1.18.1
cpprest: upgrade 2.10.15 -> 2.10.16
Zong Li (1):
Upgrade testfloat to 3e version.
niko.mauno@vaisala.com (3):
python3-setuptools-scm: Cosmetic improvement
python3-setuptools-scm: Add nativesdk to BBCLASSEXTEND
python3-attrs: Add nativesdk to BBCLASSEXTEND
Change-Id: I696f29557eafda5f9f9d6e26525e1a5819982a4b
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pytoml_0.1.21.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pytoml_0.1.21.bb
index b09005e..1533a89 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pytoml_0.1.21.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pytoml_0.1.21.bb
@@ -15,6 +15,11 @@
file://run-ptest \
"
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-stringold \
+ "
+
RDEPENDS_${PN}-ptest += " \
${PYTHON_PN}-pytest \
"