nicole: NCSI channel selector

NCSI channel number is selected depending on GPIO state of a pin
described in the device tree (gpio/nsci_cfg node).
Currently, this pin is controlled via MCU, and its state represents
Nicole's physical position inside a fabric.

Channel selector scheme:
* GPIO pin is LOW: channel 0;
* GPIO pin is HIGH: channel 1;
* invalid configuration or error: channel 0.

After changing pin's state it is necessary to reboot the BMC to apply
new channel number.

(From meta-yadro rev: 2661355417e52d968e9845298c37cae8ff1dfe6b)

Signed-off-by: Artem Senichev <a.senichev@yadro.com>
Change-Id: I8eeac34f71197fc110e41d186dd1fd4d2f1ef064
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-yadro/meta-nicole/recipes-kernel/linux/linux-aspeed_%.bbappend b/meta-yadro/meta-nicole/recipes-kernel/linux/linux-aspeed_%.bbappend
index bd3e475..bf06fe2 100644
--- a/meta-yadro/meta-nicole/recipes-kernel/linux/linux-aspeed_%.bbappend
+++ b/meta-yadro/meta-nicole/recipes-kernel/linux/linux-aspeed_%.bbappend
@@ -1,6 +1,7 @@
 FILESEXTRAPATHS_prepend_nicole := "${THISDIR}/${PN}:"
 SRC_URI += "file://nicole.cfg \
             file://arch \
+            file://0001-Add-NCSI-channel-selector.patch \
 "
 
 # Merge source tree by original project with our layer of additional files