meta-openembedded: subtree update:53d431639a..e4ac09169d
Andreas Müller (9):
file-roller: add gsettings to inherit
tracker: add gsettings to inherit
nautilus: add gsettings to inherit
libgweather: add gsetings & upstream-version-is-even to inherit
gnome-settings-daemon: add gsettings to inherit
gnome-terminal: add gsettings to inherit
parole: upgrade 1.0.4 -> 1.0.5
exo: upgrade 0.12.8 -> 0.12.9
gedit: add gsettings to inherit
Changqing Li (1):
dnsmasq.conf: fix dnsmasq path
Denys Dmytriyenko (1):
recipes: rename distro_features_check to features_check
Jan Luebbe (6):
openct: merge do_install and do_install_append
pcsc-lite: add support for native builds
opensc: use pcsc-lite instead of openct by default
opensc: add support for native builds
libp11: add support for native builds
softhsm: add recipe
Kai Kang (1):
mariadb: replace dependency readline with libedit
Khem Raj (6):
dlm: Drop -fstack-clash-protection for clang
ruli: Fix install step and build samples too
libkcapi: Update patch to upstream submitted one
sanlock: Use python3 and add sanlock user/group
sanlock: Replace cp -a with cp -R --no-dereference
nodejs: libatomic patch should be target specific
Lei YU (1):
googletest: move to release 1.10.0
Nicola Lunghi (4):
python3-importlib-metadata: fix class-target overriding default dependencies
python-configparser: Add native and nativesdk to BBCLASSEXTEND
python-contextlib2: Add native and nativesdk to BBCLASSEXTEND
python-scandir: Add native and nativesdk to BBCLASSEXTEND
Paul Barker (1):
liblockfile: Rename patch
Qi.Chen@windriver.com (1):
python-jsonschema: add missing dependency
Ross Burton (1):
python-babel: add BBCLASSEXTEND for native/nativesdk
Rouven Czerwinski (1):
python-pyelftools: add recipes
Stefan Agner (2):
haveged: use the Fedora service file available from upstream
networkmanager: do not deploy unnecessary udev rule file
Wang Mingyu (3):
mcelog: upgrade 1.65 -> 1.66
hwdata: upgrade 0.328 -> 0.329
libdev-checklib-perl: upgrade 1.13 -> 1.14
Zang Ruochen (17):
python-zopeinterface: upgrade 4.6.0 -> 4.7.1
python-yappi: upgrade 0.98 -> 1.0
python-xstatic: upgrade 1.0.1 -> 1.0.2
python-xlrd: upgrade 1.1.0 -> 1.2.0
python-urllib3: upgrade 1.25.6 -> 1.25.7
python-tzlocal: upgrade 1.5.1 -> 2.0.0
python-twitter: upgrade 3.7.0 -> 3.8.0
python-twisted: upgrade 19.7.0 -> 19.10.0
python3-meh: upgrade 0.47 -> 0.48
python-pyephem: upgrade 3.7.6.0 -> 3.7.7.0
python3-pykickstart: upgrade 3.20 -> 3.22
python-pyparted: upgrade 3.11.2 -> 3.11.3
libextutils-cppguess-perl: upgrade 0.12 -> 0.20
libmoo-perl: upgrade 2.003004 -> 2.003006
libdbd-sqlite-perl: upgrade 1.62 -> 1.64
libclass-method-modifiers-perl: upgrade 2.12 -> 2.13
librole-tiny-perl: upgrade 2.000006 -> 2.001004
niko.mauno@vaisala.com (2):
gitpkgv.bbclass: Use --git-dir option
gitpkgv.bbclass: Support also lightweight tags
Change-Id: I00fb24df7bb3849ed0c9337a66623d9b4cba5999
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-perl/recipes-perl/libmoo/libmoo-perl_2.003006.bb b/meta-openembedded/meta-perl/recipes-perl/libmoo/libmoo-perl_2.003006.bb
new file mode 100644
index 0000000..0bd0eae
--- /dev/null
+++ b/meta-openembedded/meta-perl/recipes-perl/libmoo/libmoo-perl_2.003006.bb
@@ -0,0 +1,44 @@
+SUMMARY = "Moo - Minimalist Object Orientation (with Moose compatibility)"
+DESCRIPTION = "This module us an extremely light-weight subset of \"Moose\" \
+optimised for rapid startup and \"pay only for what you use\"."
+
+SECTION = "libs"
+
+HOMEPAGE = "http://metapan.org/release/Moo/"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://README;beginline=742;endline=787;md5=2ee6a628a04af08d75bc73a86da86d4a"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/H/HA/HAARG/Moo-${PV}.tar.gz"
+SRC_URI[md5sum] = "53af7e7849492a8e3994ee379d12e348"
+SRC_URI[sha256sum] = "bcb2092ab18a45005b5e2e84465ebf3a4999d8e82a43a09f5a94d859ae7f2472"
+
+S = "${WORKDIR}/Moo-${PV}"
+
+inherit cpan
+
+RDEPENDS_${PN} = " libclass-method-modifiers-perl \
+ libdevel-globaldestruction-perl \
+ libmodule-runtime-perl \
+ librole-tiny-perl \
+ perl-module-constant \
+ perl-module-exporter \
+ perl-module-mro \
+ perl-module-scalar-util \
+"
+
+RPROVIDES_${PN} = " libmethod-inliner-perl \
+ libmethod-generate-accessor-perl \
+ libmethod-generate-buildall-perl \
+ libmethod-generate-constructor-perl \
+ libmethod-generate-demolishall-perl \
+ libmoo-perl \
+ libmoo-handlemoose-perl \
+ libmoo-handlemoose-fakemetaclass-perl \
+ libmoo-object-perl \
+ libmoo-role-perl \
+ libsub-defer-perl \
+ libsub-quote-perl \
+"
+
+BBCLASSEXTEND = "native"