meta-intel-openbmc: Enable PLT_RST in x86-power-control

This enables the x86-power-control build option to use PLT_RST
to detect warm resets.

Tested:
Confirmed that PLT_RST is detected in x86-power-control after
enabling this option.

Change-Id: I044482b50d7b1f7a1fa82921fc4bfcf60ae4287a
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
diff --git a/meta-intel-openbmc/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend b/meta-intel-openbmc/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend
new file mode 100644
index 0000000..5d47989
--- /dev/null
+++ b/meta-intel-openbmc/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend
@@ -0,0 +1,2 @@
+# Use PLT_RST to detect warm resets
+EXTRA_OECMAKE_intel += "-DUSE_PLT_RST=ON"