meta-openembedded: subtree update:3a9262866d..55de2d06ad
Adrian Bunk (1):
python-more-itertools: Add PE
Andreas Müller (1):
Add gnome help packages to image according to IMAGE_LINGUAS
Andreas Oberritter (2):
live555: Move test progams out of main package
pugixml: Update to version 1.10
André Draszik (7):
gyp: update to fcd686f1880f
gyp: provide a python2 version of gyp as gyp-py2
nodejs: ensure to use correct compiler & flags always
nodejs: delete all bundled deps in do_unpack() if needed
nodejs: allow use of system gyp
nodejs: use OE-provided compiler flags (arm)
nodejs: support long directory names for ${B} / ${S}
Denys Dmytriyenko (1):
mbedtls: upgrade 2.16.2 -> 2.16.3
Fabio Berton (5):
python-importlib-metadata: Add native and nativesdk to BBCLASSEXTEND
python-more-itertools: Add native and nativesdk to BBCLASSEXTEND
python-pathlib2: Add native and nativesdk to BBCLASSEXTEND
python-zipp: Add native and nativesdk to BBCLASSEXTEND
python3-importlib-metadata: RDEPEND python3-misc only for target and nativesdk
Khem Raj (13):
sip: Upgrade to 4.19.19
cherokee: Update to latest
cherokee: Fix build when time_t is 64bit
tvheadend: Update to tip of master
lowpan-tools: Blacklist as its deprecated use wpan-tools instead
pidgin-sipe: Fix build when time_t is 64bit
open-vm-tools: Enable tirpc explicitly, fix build with 64bit time_t
python-systemd: Include endian.h for htobe16
tvheadend: Fix build with 64bit time_t
tvheadend: Set CLEANBROKEN
layer.conf: Add ttf-roboto->fontconfig to SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS
layer.conf: Add phpmyadmin->php dep to SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS
python-six: Update to 1.13.0
Michael Scott (1):
modemmanager: Upgrade 1.10.6 -> 1.10.8
Nicola Lunghi (5):
python3-gmqtt: add recipe
python-backports-abc: update to 0.5.0
python-rfc3339-validator: add recipe
python-rfc3986-validator: add recipe
python-dbus-next: fix recipe position
Peace Lee (1):
guider: upgrade 3.9.4 -> 3.9.6
Trevor Gamblin (4):
python3-werkzeug: upgrade from 0.14.1 to 0.16.0
python3-flask: upgrade from 1.0.2 to 1.1.1
python3-itsdangerous: upgrade from 0.24 to 1.1.0
zabbix: upgrade 4.2.8 -> 4.4.1
Yi Zhao (1):
python-ipy: add recipes
Zang Ruochen (15):
fuse3: upgrade 3.7.0 -> 3.8.0
python-alembic: upgrade 1.2.1 -> 1.3.0
python-astroid: upgrade 2.3.2 -> 2.3.3
python-bitarray: upgrade 1.0.1 -> 1.1.0
python-cffi: upgrade 1.13.1 -> 1.13.2
python-dateutil: upgrade 2.8.0 -> 2.8.1
python-psutil: upgrade 5.6.3 -> 5.6.5
python-pycryptodome: upgrade 3.9.0 -> 3.9.3
python-pyparsing: upgrade 2.4.2 -> 2.4.5
python-pytest-helpers-namespace: upgrade 2016.7.10 -> 2019.1.8
python-pytest-runner: upgrade 5.1 -> 5.2
python-pytest-tempdir: upgrade 2016.8.20 -> 2019.10.12
python-requests-oauthlib: upgrade 0.8.0 -> 1.3.0
python-tornado: upgrade 5.1 -> 6.0.3
python-tqdm: upgrade 4.31.1 -> 4.38.0
Zheng Ruoqin (1):
f2fs-tools: Update Homepage
Change-Id: Ifc2d7bac36a719f2a4ead82b491d9817f212c56f
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-filesystems/recipes-support/fuse/fuse3_3.8.0.bb b/meta-openembedded/meta-filesystems/recipes-support/fuse/fuse3_3.8.0.bb
new file mode 100644
index 0000000..b5bbe04
--- /dev/null
+++ b/meta-openembedded/meta-filesystems/recipes-support/fuse/fuse3_3.8.0.bb
@@ -0,0 +1,48 @@
+SUMMARY = "Implementation of a fully functional filesystem in a userspace program"
+DESCRIPTION = "FUSE (Filesystem in Userspace) is a simple interface for userspace \
+ programs to export a virtual filesystem to the Linux kernel. FUSE \
+ also aims to provide a secure method for non privileged users to \
+ create and mount their own filesystem implementations. \
+ "
+HOMEPAGE = "https://github.com/libfuse/libfuse"
+SECTION = "libs"
+LICENSE = "GPLv2 & LGPLv2"
+LIC_FILES_CHKSUM = "file://GPL2.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://LGPL2.txt;md5=4fbd65380cdd255951079008b364516c \
+ file://LICENSE;md5=a55c12a2d7d742ecb41ca9ae0a6ddc66"
+
+SRC_URI = "https://github.com/libfuse/libfuse/releases/download/fuse-${PV}/fuse-${PV}.tar.xz \
+"
+SRC_URI[md5sum] = "f184004cd3724f579cd602fa5232681b"
+SRC_URI[sha256sum] = "4a464f6df782a1dca1f7e85bf64ff6ece9547b389557aae4160371cb1c898d61"
+
+S = "${WORKDIR}/fuse-${PV}"
+
+UPSTREAM_CHECK_URI = "https://github.com/libfuse/libfuse/releases"
+UPSTREAM_CHECK_REGEX = "fuse\-(?P<pver>3(\.\d+)+).tar.xz"
+
+inherit meson pkgconfig
+
+DEPENDS = "udev"
+
+PACKAGES =+ "fuse3-utils"
+
+RPROVIDES_${PN}-dbg += "fuse3-utils-dbg"
+
+RRECOMMENDS_${PN}_class-target = "kernel-module-fuse fuse3-utils"
+
+FILES_${PN} += "${libdir}/libfuse3.so.*"
+FILES_${PN}-dev += "${libdir}/libfuse3*.la"
+
+EXTRA_OEMESON += " \
+ -Dexamples=false \
+"
+
+# Forbid auto-renaming to libfuse3-utils
+FILES_fuse3-utils = "${bindir} ${base_sbindir}"
+DEBIAN_NOAUTONAME_fuse3-utils = "1"
+DEBIAN_NOAUTONAME_${PN}-dbg = "1"
+
+do_install_append() {
+ rm -rf ${D}${base_prefix}/dev
+}