meta-openpower: Add hostboot-settings packaging

This installs the system service and bash program.

Change-Id: If6d73a9ac37d20782dfc0f86f3170b84371461a7
Signed-off-by: Joel Stanley <joel@jms.id.au>
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/hostboot-settings.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/hostboot-settings.bb
new file mode 100644
index 0000000..39beb48
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/hostboot-settings.bb
@@ -0,0 +1,19 @@
+SUMMARY = "OpenPower Hostboot Boot settings tool"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit obmc-phosphor-systemd
+inherit allarch
+
+SRC_URI = "file://hb_settings"
+SYSTEMD_SERVICE_${PN} += "hostboot-settings.service"
+
+do_fetch[noexec] = "1"
+do_patch[noexec] = "1"
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+    install -d ${D}${bindir}
+    install -m 0755 ${WORKDIR}/hb_settings ${D}${bindir}
+}