fans:monitor:witherspoon: Install config.json file
In prep for switching the witherspoon machine over to using a runtime
fan monitoring JSON configuration, install the configuration file into
the image now.
Tested:
Verified both `monitor.yaml` and `config.json` in phosphor-fan
Built/installed witherspoon image and config.json file present
Verified YAML config still used instead of present JSON config
(From meta-ibm rev: 36206800a699a1429d30ad32a36e4f960ac6c7b4)
Change-Id: I75d72a2731f201d37d38c9d436eff2af522bc6da
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
index 8f2097c..9307f17 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
@@ -1 +1,14 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+
+SRC_URI_witherspoon += "file://monitor.yaml"
+SRC_URI_witherspoon += "file://config.json"
+
+do_install_append_witherspoon() {
+ DEST=${D}${monitor_datadir}
+ install -D monitor.yaml ${D}${monitor_datadir}/monitor.yaml
+ install -d ${D}/${datadir}/phosphor-fan-presence/monitor/
+ install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/
+}
+
+FILES_${PN}_witherspoon += "${datadir}/phosphor-fan-presence/monitor/config.json"
+FILES_${PN}_witherspoon += "${monitor_datadir}/monitor.yaml"