meta-openembedded: subtree update:18506b797b..c986cbed93
Adrian Bunk (7):
gpsd: Backport a memory leak fix
gpsd: Stop depending on chrpath-native
klibc: Upgrade 2.0.6 -> 2.0.7
gerbera: Upgrade 1.3.0 -> 1.3.2
gstd: Fix the version number
webrtc-audio-processing: Upgrade 0.3 -> 0.3.1
vlc: Upgrade 3.0.6 -> 3.0.8
Andreas Müller (15):
itstool: rework native shebang and add class to make native itstool work
yelp-tools: use itstools.bbclass
yelp-xsl: use itstool.bbclass
yelp: use itstool.bbclass
gnome-help.bbclass: Handle gnome-help files with new distro feature 'helpfiles'
zenity: rework recipe
dconf: extend to native build for upcoming gdm
dconf-editor: upgrade 3.32.0 -> 3.34.0
gtksourceview4: upgrade 4.2.0 -> 4.4.0
gnome-menus3: upgrade 3.10.1 -> 3.32.0
gnome-desktop3: upgrade 3.34.0 -> 3.34.1
gnome-bluetooth: upgrade 3.32.1 -> 3.34.0
gspell: upgrade 1.8.1 -> 1.8.2
gnome-system-monitor: upgrade 3.32.0 -> 3.32.1
network-manager-applet: upgrade 1.8.22 -> 1.8.23 / build with meson / cleanup
Luca Boccassi (4):
dbus-broker: 19 -> 21
dbus-broker: backport patches from master
dbus-broker: build with SELinux if it's enabled via DISTRO_FEATURES
dbus-broker: add patch to fix build with musl libc
Trevor Gamblin (1):
rsyslog: upgrade from v8.1908.0 to v8.1910.0
Zang Ruochen (4):
python-bitarray: upgrade 0.8.3 -> 1.0.1
python-can: upgrade 2.2.1 -> 3.3.2
python-daemonize: upgrade 2.4.7 -> 2.5.0
xmlsec1: upgrade 1.2.28 -> 1.2.29
Zheng Ruoqin (2):
keepalived: upgrade 2.0.16 -> 2.0.19
postfix: upgrade 3.4.5 -> 3.4.7
Change-Id: Ibff272f163bb42473022825cfb17a284a0019e83
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-gnome/classes/gnome-help.bbclass b/meta-openembedded/meta-gnome/classes/gnome-help.bbclass
new file mode 100644
index 0000000..967091b
--- /dev/null
+++ b/meta-openembedded/meta-gnome/classes/gnome-help.bbclass
@@ -0,0 +1,69 @@
+# Class to pack gnome help files or delete them during install
+# There are the following cases:
+#
+# if 'helpfiles' not in DISTRO_FEATURES
+# delete all help contants during install
+# else
+# if PACKAGE_NO_HELP_SPLIT == 1
+# pack all help files to ${PN}-help
+# else
+# pack all help files to ${PN}-help-<lingua>
+
+FILES_${PN}-help = "${datadir}/*/translations"
+
+# Dummy to get yelp build & PACKAGE_NO_HELP_SPLIT set 1
+PACKAGES_append = " ${PN}-help"
+FILES_${PN}-help = "${datadir}/help"
+RRECOMMENDS_${PN}-help = "${@bb.utils.contains('DISTRO_FEATURES','helpfiles','yelp','',d)}"
+
+do_install_append() {
+ if ${@bb.utils.contains('DISTRO_FEATURES','helpfiles','false','true',d)}; then
+ rm -rf ${D}${datadir}/help/*
+ fi
+}
+
+python gnome_do_split_help() {
+ if bb.utils.contains('DISTRO_FEATURES', 'helpfiles', False, True, d):
+ return
+
+ if (d.getVar('PACKAGE_NO_HELP_SPLIT') == '1'):
+ # all help files go to ${
+ bb.debug(1, "package requested not splitting help-files")
+ return
+
+ packages = (d.getVar('PACKAGES') or "").split()
+ datadir = d.getVar('datadir')
+ dvar = d.getVar('PKGD')
+ pn = d.getVar('PN')
+
+ if pn + '-help' in packages:
+ packages.remove(pn + '-help')
+
+ helpdir = os.path.join(dvar + datadir, 'help')
+
+ if not cpath.isdir(helpdir):
+ bb.warn("No help files in this package - remove gnome-help from inherit?")
+ return
+
+ helps = os.listdir(helpdir)
+
+ summary = d.getVar('SUMMARY') or pn
+ description = d.getVar('DESCRIPTION') or ""
+ locale_section = d.getVar('LOCALE_SECTION')
+ mlprefix = d.getVar('MLPREFIX') or ""
+ for l in sorted(helps):
+ ln = legitimize_package_name(l)
+ pkg = pn + '-help-' + ln
+ packages.append(pkg)
+ d.setVar('FILES_' + pkg, os.path.join(datadir, 'help', l))
+ d.setVar('RRECOMMENDS_' + pkg, '%syelp' % mlprefix)
+ d.setVar('SUMMARY_' + pkg, '%s - %s help' % (summary, l))
+ d.setVar('DESCRIPTION_' + pkg, '%s This package contains language help files for the %s locale.' % (description, l))
+ if locale_section:
+ d.setVar('SECTION_' + pkg, locale_section)
+
+ d.setVar('PACKAGES', ' '.join(packages))
+}
+
+PACKAGESPLITFUNCS_prepend = "gnome_do_split_help "
+