meta-openembedded: subtree update:18506b797b..c986cbed93

Adrian Bunk (7):
      gpsd: Backport a memory leak fix
      gpsd: Stop depending on chrpath-native
      klibc: Upgrade 2.0.6 -> 2.0.7
      gerbera: Upgrade 1.3.0 -> 1.3.2
      gstd: Fix the version number
      webrtc-audio-processing: Upgrade 0.3 -> 0.3.1
      vlc: Upgrade 3.0.6 -> 3.0.8

Andreas Müller (15):
      itstool: rework native shebang and add class to make native itstool work
      yelp-tools: use itstools.bbclass
      yelp-xsl: use itstool.bbclass
      yelp: use itstool.bbclass
      gnome-help.bbclass: Handle gnome-help files with new distro feature 'helpfiles'
      zenity: rework recipe
      dconf: extend to native build for upcoming gdm
      dconf-editor: upgrade 3.32.0 -> 3.34.0
      gtksourceview4: upgrade 4.2.0 -> 4.4.0
      gnome-menus3: upgrade 3.10.1 -> 3.32.0
      gnome-desktop3: upgrade 3.34.0 -> 3.34.1
      gnome-bluetooth: upgrade 3.32.1 -> 3.34.0
      gspell: upgrade 1.8.1 -> 1.8.2
      gnome-system-monitor: upgrade 3.32.0 -> 3.32.1
      network-manager-applet: upgrade 1.8.22 -> 1.8.23 / build with meson / cleanup

Luca Boccassi (4):
      dbus-broker: 19 -> 21
      dbus-broker: backport patches from master
      dbus-broker: build with SELinux if it's enabled via DISTRO_FEATURES
      dbus-broker: add patch to fix build with musl libc

Trevor Gamblin (1):
      rsyslog: upgrade from v8.1908.0 to v8.1910.0

Zang Ruochen (4):
      python-bitarray: upgrade 0.8.3 -> 1.0.1
      python-can: upgrade 2.2.1 -> 3.3.2
      python-daemonize: upgrade 2.4.7 -> 2.5.0
      xmlsec1: upgrade 1.2.28 -> 1.2.29

Zheng Ruoqin (2):
      keepalived: upgrade 2.0.16 -> 2.0.19
      postfix: upgrade 3.4.5 -> 3.4.7

Change-Id: Ibff272f163bb42473022825cfb17a284a0019e83
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb b/meta-openembedded/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
new file mode 100644
index 0000000..828caa8
--- /dev/null
+++ b/meta-openembedded/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Gstreamer Daemon"
+SUMMARY = "GStreamer framework for controlling audio and video streaming using TCP connection messages"
+HOMEPAGE = "https://developer.ridgerun.com/wiki/index.php?title=Gstd-1.0"
+SECTION = "multimedia"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad gstreamer1.0-rtsp-server json-glib libdaemon"
+
+SRCBRANCH ?= "master"
+SRCREV = "3526d0ffdbccc375db7d5fe33a72c68b134657c2"
+SRC_URI = "git://git@github.com/RidgeRun/gstd-1.x.git;protocol=https;branch=${SRCBRANCH} \
+           file://0001-gstd-yocto-compatibility.patch \
+           file://0001-Look-for-gtk-doc.make-in-builddir.patch \
+           "
+S = "${WORKDIR}/git"
+
+# Remove the +really when upstream version is > 1.0
+PV = "1.0+really0.6.3"
+
+inherit autotools pkgconfig gettext gtk-doc
+
+do_configure_prepend() {
+	sed -i -e "s|include \$(top_builddir)/docs/gtk-doc.make||g" ${S}/docs/reference/gstd/Makefile.am
+}