Run oe-stylize on our files
In all of our recipes, we should be following yoctos lead on formatting,
order, and other things, for consistency in our meta layers.
This commit runs oe-stylize.py on all of our files. The types of
changes being made can be seen in the commit, but amount to:
1. Setting an explicit key ordering
2. Sectioning the files appropriately
3. Applying rules checking to our files
At some point in the near future, we would turn this on as part of
repotest, but some minor changes need to be upstreamed to meta-oe (WIP)
to make that happen.
Looking for input on whether this is something we'd like to do, and
whether the diffs below look reasonable to folks.
Signed-off-by: Ed Tanous <edtanous@google.com>
Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
diff --git a/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb b/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb
index e611b46..c0137e3 100644
--- a/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb
+++ b/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb
@@ -1,10 +1,15 @@
SUMMARY = "C++ bindings for linux gpio APIs"
DESCRIPTION = "C++ bindings for linux gpio APIs."
HOMEPAGE = "http://github.com/openbmc/gpioplus"
-PR = "r1"
-PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+SRCREV = "8944f2e24ad8152793af010906faf06607f0e04b"
+PV = "0.1+git${SRCPV}"
+PR = "r1"
+
+SRC_URI += "git://github.com/openbmc/gpioplus;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
inherit meson pkgconfig
@@ -12,8 +17,3 @@
-Dexamples=false \
-Dtests=disabled \
"
-
-SRC_URI += "git://github.com/openbmc/gpioplus;branch=master;protocol=https"
-SRCREV = "8944f2e24ad8152793af010906faf06607f0e04b"
-
-S = "${WORKDIR}/git"