Run oe-stylize on our files

In all of our recipes, we should be following yoctos lead on formatting,
order, and other things, for consistency in our meta layers.

This commit runs oe-stylize.py on all of our files.  The types of
changes being made can be seen in the commit, but amount to:

1. Setting an explicit key ordering
2. Sectioning the files appropriately
3. Applying rules checking to our files

At some point in the near future, we would turn this on as part of
repotest, but some minor changes need to be upstreamed to meta-oe (WIP)
to make that happen.

Looking for input on whether this is something we'd like to do, and
whether the diffs below look reasonable to folks.

Signed-off-by: Ed Tanous <edtanous@google.com>
Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
diff --git a/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb b/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb
index cc92695..92979b9 100644
--- a/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb
+++ b/meta-phosphor/recipes-phosphor/mrw/mrw-api-native.bb
@@ -1,8 +1,12 @@
 SUMMARY = "Phosphor OpenBMC machine readable workbook API modules"
 DESCRIPTION = "The API for the MRW XML generated by the Serverwiz tool"
-PR = "r1"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
+DEPENDS += "libxml-simple-perl-native libjson-perl-native"
+SRCREV = "${MRW_API_SRCREV}"
+PR = "r1"
+
+SRC_URI += "${MRW_API_SRC_URI}"
 
 S = "${WORKDIR}/git"
 
@@ -11,11 +15,6 @@
 inherit cpan-base
 inherit mrw-rev
 
-DEPENDS += "libxml-simple-perl-native libjson-perl-native"
-
-SRC_URI += "${MRW_API_SRC_URI}"
-SRCREV = "${MRW_API_SRCREV}"
-
 do_install() {
     install -d ${D}${PERLLIBDIRS:class-native}/site_perl/${PERLVERSION}/mrw
     install -m 0755 scripts/Targets.pm ${D}${PERLLIBDIRS:class-native}/site_perl/${PERLVERSION}/mrw/Targets.pm