Set MaxBootCycleCount for progresscodes on IBM systems
MaxBootCycleCount is a dbus property that is used to indicate
the maximum number of boot cycles that the post-code-manager
daemon can store the progress codes for, before it starts
wrapping.
Unlike Intel postcodes, IBM progress codes are huge and it is
possible to get close to 230+ progress codes per boot cycle, so
tweaking this value to 5 boot cycles for IBM systems so that
we can get less number of log entries on a redfish GET request.
Signed-off-by: Manojkiran Eda <manojkiran.eda@gmail.com>
Change-Id: Ida10e73992b01535d57c844d83366d786cd448e2
diff --git a/meta-ibm/recipes-phosphor/state/phosphor-post-code-manager_%.bbappend b/meta-ibm/recipes-phosphor/state/phosphor-post-code-manager_%.bbappend
new file mode 100644
index 0000000..f8ff901
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/state/phosphor-post-code-manager_%.bbappend
@@ -0,0 +1,4 @@
+# Set MaxBootCycleCount to 5 on IBM systems
+EXTRA_OECMAKE_append_p10bmc = "-DMAX_BOOT_CYCLE_COUNT=5"
+EXTRA_OECMAKE_append_witherspoon-tacoma = "-DMAX_BOOT_CYCLE_COUNT=5"
+