stdplus: Use meson instead of autotools

This will allow us to get rid of autotools in the upstream sources.

(From meta-phosphor rev: 6838e7ce10ee9970aeb27262dcc45d11449f21d3)

Change-Id: I57490fd3635357bc203e8fb0e40b27217e5d8f79
Signed-off-by: William A. Kennington III <wak@google.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb b/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb
index 45a699b..845b96e 100644
--- a/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb
+++ b/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb
@@ -6,15 +6,11 @@
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
 
-inherit autotools pkgconfig
+inherit meson pkgconfig
 
-DEPENDS += " \
-        autoconf-archive-native \
-        "
-
-EXTRA_OECONF_append += " \
-        --disable-examples \
-        --disable-tests \
+EXTRA_OEMESON = " \
+        -Dexamples=false \
+        -Dtests=disabled \
         "
 
 SRC_URI += "git://github.com/openbmc/stdplus"