meta-google: Refactor networkd reloads to one place

We want to have common logging and conditional routines when we talk to
networkd.

Change-Id: I44c83c8137399d2126c565a1f753520603a9f97b
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/meta-google/recipes-google/networking/gbmc-net-common.bb b/meta-google/recipes-google/networking/gbmc-net-common.bb
index 1f709b4..1a3ca77 100644
--- a/meta-google/recipes-google/networking/gbmc-net-common.bb
+++ b/meta-google/recipes-google/networking/gbmc-net-common.bb
@@ -4,6 +4,7 @@
 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
 
 SRC_URI += " \
+  file://gbmc-net-lib.sh \
   file://gbmc-ra.sh \
   "
 S = "${WORKDIR}"
@@ -20,6 +21,7 @@
 
 do_install() {
   install -d -m0755 ${D}${datadir}
+  install -m0644 ${S}/gbmc-net-lib.sh ${D}${datadir}/
   install -m0644 ${S}/gbmc-ra.sh ${D}${datadir}/
 }