meta-raspberrypi: subtree update:a6f1233d52..0d398a3b71

Christopher Clark (1):
      linux-raspberrypi: bump to 5.4.50 since upstream was force-pushed

Leon Anavi (2):
      rpi-u-boot-scr: Create uboot.env via boot.cmd.in
      libubootenv_%.bbappend: Add fw_env.config

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I8994cad6a13e2ae6f74c7a0a34061a9c4700a124
diff --git a/meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend b/meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend
new file mode 100644
index 0000000..22d1bdc
--- /dev/null
+++ b/meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend
@@ -0,0 +1,12 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI_append_rpi = " \
+    file://fw_env.config \
+"
+
+DEPENDS_append_rpi = " rpi-u-boot-scr"
+
+do_install_append_rpi () {
+    install -d ${D}${sysconfdir}
+    install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+}