meta-ibm: use ibm-ac-server MACHINEOVERRIDE
Use an override in bbappends in meta-witherspoon as described and
recommended in the "following best practices when creating layers"
section of the the Yocto development tasks manual.
ibm-ac-server represents common machine configuration shared by all of
IBMs "Accelerated Compute" class of servers. Apply it wherever any
variables are un-bounded by any override.
This enables more flexible use of meta-witherspoon in build
configurations, and easy addition of machines to the layer.
(From meta-ibm rev: bb0e1d0699a4b9905c053c94af7d882cd71779fc)
Change-Id: I82f7338b0d7a64b5e7a67e19bcdff07f48a332d4
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/openpower-ipmi-oem_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/openpower-ipmi-oem_%.bbappend
index 588f23e..ae379af 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/openpower-ipmi-oem_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/openpower-ipmi-oem_%.bbappend
@@ -1,5 +1,5 @@
-DEPENDS_append = " acx22-yaml-config"
+DEPENDS_append_ibm-ac-server = " acx22-yaml-config"
-EXTRA_OECONF = " \
+EXTRA_OECONF_ibm-ac-server = " \
INVSENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-inventory-sensors.yaml \
"