Convert pam_pwhistory config to pwhistory.conf
With libpam 1.5.3, pam_pwhistory added support to get configuration
options from pwhistory.conf similar to faillock and pwquality. This
converts the pam_pwhistory config options to pwhistory.conf to match
faillock and pwquality.
Tested:
Confirmed that the remember setting works correctly from pwhistory.conf.
Confirmed that an existing pwhistory remember setting gets converted to
pwhistory.conf, if needed.
Signed-off-by: Jason M. Bills <jason.m.bills@linux.intel.com>
Change-Id: I8ec0c8b60f02f0e5aa97b3254225e9a5488cdb54
diff --git a/meta-phosphor/recipes-extended/pam/libpam_%.bbappend b/meta-phosphor/recipes-extended/pam/libpam_%.bbappend
index d9ffdac..0007c6f 100644
--- a/meta-phosphor/recipes-extended/pam/libpam_%.bbappend
+++ b/meta-phosphor/recipes-extended/pam/libpam_%.bbappend
@@ -5,6 +5,7 @@
file://pam.d/common-auth \
file://pam.d/common-session \
file://faillock.conf \
+ file://pwhistory.conf \
file://convert-pam-configs.service \
file://convert-pam-configs.sh \
"
@@ -25,6 +26,7 @@
install -d ${D}/etc/security
install -m 0644 ${WORKDIR}/faillock.conf ${D}/etc/security
+ install -m 0644 ${WORKDIR}/pwhistory.conf ${D}/etc/security
install -d ${D}${bindir}
install -m 0755 ${WORKDIR}/convert-pam-configs.sh ${D}${bindir}