meta-facebook: Move phoshphor-state-manager scripts into subdirectory

Description:
Move scripts under /usr/libexec/ to /usr/libexec/phosphor-state-manager/.

Test Case:
Check file path under BMC console.

Change-Id: Ia4178b62653e90dd6e0ae567df693f03468257bb
Signed-off-by: Delphine CC Chiu <Delphine_CC_Chiu@wiwynn.com>
diff --git a/meta-facebook/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-facebook/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index 8c60835..b0acf75 100644
--- a/meta-facebook/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-facebook/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -44,14 +44,14 @@
     install -m 0644 ${WORKDIR}/*.service ${D}${systemd_system_unitdir}/
 
     install -d ${D}${libexecdir}/${PN}
-    install -m 0777 ${WORKDIR}/chassis-poweroff ${D}${libexecdir}/
-    install -m 0777 ${WORKDIR}/chassis-poweron ${D}${libexecdir}/
-    install -m 0777 ${WORKDIR}/chassis-powercycle ${D}${libexecdir}/
-    install -m 0777 ${WORKDIR}/host-poweroff ${D}${libexecdir}/
-    install -m 0777 ${WORKDIR}/host-poweron ${D}${libexecdir}/
-    install -m 0777 ${WORKDIR}/host-powercycle ${D}${libexecdir}/
-    install -m 0777 ${WORKDIR}/host-powerreset ${D}${libexecdir}/
-    install -m 0777 ${WORKDIR}/power-cmd ${D}${libexecdir}/
+    install -m 0777 ${WORKDIR}/chassis-poweroff ${D}${libexecdir}/${PN}/
+    install -m 0777 ${WORKDIR}/chassis-poweron ${D}${libexecdir}/${PN}/
+    install -m 0777 ${WORKDIR}/chassis-powercycle ${D}${libexecdir}/${PN}/
+    install -m 0777 ${WORKDIR}/host-poweroff ${D}${libexecdir}/${PN}/
+    install -m 0777 ${WORKDIR}/host-poweron ${D}${libexecdir}/${PN}/
+    install -m 0777 ${WORKDIR}/host-powercycle ${D}${libexecdir}/${PN}/
+    install -m 0777 ${WORKDIR}/host-powerreset ${D}${libexecdir}/${PN}/
+    install -m 0777 ${WORKDIR}/power-cmd ${D}${libexecdir}/${PN}/
     install -m 0777 ${WORKDIR}/power-ctrl-init ${D}${libexecdir}/${PN}/
 }