meta-fii/meta-kudo: Using Entity manager

1- Using Entity manager
2- Using Entity manger PID
3- Using EntityIds

Signed-off-by: mustafa <mustafa.shehabi@fii-na.com>
Change-Id: Icfaae4556e03b99e7b44baa15f22d6a453d9bf54
Signed-off-by: mohaimen.alsamarai@fii-na.com <mohaimen.alsamarai@fii-na.com>
diff --git a/meta-fii/meta-kudo/recipes-phosphor/configuration/entity-manager_%.bbappend b/meta-fii/meta-kudo/recipes-phosphor/configuration/entity-manager_%.bbappend
new file mode 100644
index 0000000..003414e
--- /dev/null
+++ b/meta-fii/meta-kudo/recipes-phosphor/configuration/entity-manager_%.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS_prepend_kudo := "${THISDIR}/${PN}:"
+
+SRC_URI_append_kudo = "file://kudo.json"
+
+do_install_append_kudo () {
+        install -m 0644 -D ${WORKDIR}/kudo.json ${D}/usr/share/entity-manager/configurations/kudo.json
+}