meta-inventec: add meta-starscream machine

The meta-starscream equipped with Aspeed AST2600 BMC SoC.

Tested: Build Starscream image and load on the target hardware.

Change-Id: I8c37a9f11980e3273e4c21ce80d23500c870895c
Signed-off-by: Jason Lin Ying Yen <lin.jasonyy@inventec.com>
diff --git a/meta-inventec/meta-starscream/recipes-phosphor/leds/starscream-led-manager-config-native.bb b/meta-inventec/meta-starscream/recipes-phosphor/leds/starscream-led-manager-config-native.bb
new file mode 100644
index 0000000..ba88a9a
--- /dev/null
+++ b/meta-inventec/meta-starscream/recipes-phosphor/leds/starscream-led-manager-config-native.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Phosphor LED Group Management for Starscream"
+PR = "r1"
+
+#Common code for packages distributed without a license that want Apache-2.0.
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit native
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml"
+S = "${WORKDIR}"
+
+# Copies example led layout yaml file
+do_install() {
+    SRC=${S}
+    DEST=${D}${datadir}/phosphor-led-manager
+    install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}