meta-openembedded: subtree update:19528ba2a6..ef1b17f4ef
Callaghan, Dan (1):
lmsensors: add a PACKAGECONFIG for sensord
Changqing Li (1):
ntp: fix package split wrongly when enabled usrmerge
Khem Raj (1):
remove spurious file
Nathan Rossi (3):
libeigen: Add native and nativesdk to BBCLASSEXTEND
python*-pyusb: Add native and nativesdk to BBCLASSEXTEND
python*-pyserial: Add native and nativesdk to BBCLASSEXTEND
Oleksandr Kravchuk (23):
babl: update to 0.1.62
znc: update to 1.7.4
zlog: update to 1.2.14
wipe: update to 0.24
upower: update to 0.99.11
python-pyobject: update to 3.34.0
python-pytoml: update to 0.1.21
python-cpuset: update to 1.6
libwebsockets: update to 3.2.0
libvpx: update to 1.8.1
libvdpau: update to 1.3
libmicrohttpd: update to 0.9.66
lcms: update to 2.9
libblockdev: update to 2.23
libbytesize: update to 2.1
iwd: update to 0.20
gsl: update to 2.6
gflags: update to 2.2.2
digitemp: update to 3.7.2
catch2: update to 2.9.2
botan: update to 2.11.0
agent-proxy: update to 1.97
ceres-solver: fix package version
Paul Eggleton (1):
mosquitto: update to 1.6.5
Scott Ellis (1):
wireguard: Upgrade 20190905 to 20190913
Trevor Gamblin (1):
openjpeg: upgrade 2.3.0 -> 2.3.1
Yi Zhao (1):
samba: upgrade 4.10.7 -> 4.10.8
Zang Ruochen (2):
python-dbus: upgrade 1.2.10 -> 1.2.12
python-pluggy: upgrade 0.12.0 -> 0.13.0
Zheng Ruoqin (1):
xrdp: 0.9.4 -> 0.9.11
Change-Id: I3152060569cc5af7f7950c7037f25f54191d20a9
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-multimedia/webm/libvpx_1.8.1.bb b/meta-openembedded/meta-oe/recipes-multimedia/webm/libvpx_1.8.1.bb
new file mode 100644
index 0000000..70278ec
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-multimedia/webm/libvpx_1.8.1.bb
@@ -0,0 +1,50 @@
+SUMMARY = "VPX multi-format codec"
+DESCRIPTION = "The BSD-licensed libvpx reference implementation provides en- and decoders for VP8 and VP9 bitstreams."
+HOMEPAGE = "http://www.webmproject.org/code/"
+BUGTRACKER = "http://code.google.com/p/webm/issues/list"
+SECTION = "libs/multimedia"
+LICENSE = "BSD"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d5b04755015be901744a78cc30d390d4"
+
+SRCREV = "8ae686757b708cd8df1d10c71586aff5355cfe1e"
+SRC_URI += "git://chromium.googlesource.com/webm/libvpx;protocol=https \
+ file://libvpx-configure-support-blank-prefix.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+# ffmpeg links with this and fails
+# sysroots/armv4t-oe-linux-gnueabi/usr/lib/libvpx.a(vpx_encoder.c.o)(.text+0xc4): unresolvable R_ARM_THM_CALL relocation against symbol `memcpy@@GLIBC_2.4'
+ARM_INSTRUCTION_SET = "arm"
+
+CFLAGS += "-fPIC"
+
+export CC
+export LD = "${CC}"
+
+VPXTARGET_armv5te = "armv5te-linux-gcc"
+VPXTARGET_armv6 = "armv6-linux-gcc"
+VPXTARGET_armv7a = "armv7-linux-gcc"
+VPXTARGET ?= "generic-gnu"
+
+CONFIGUREOPTS = " \
+ --target=${VPXTARGET} \
+ --enable-vp9 \
+ --enable-libs \
+ --disable-install-docs \
+ --disable-static \
+ --enable-shared \
+ --prefix=${prefix} \
+ --libdir=${libdir} \
+ --size-limit=16384x16384 \
+"
+
+do_configure() {
+ ${S}/configure ${CONFIGUREOPTS}
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+ chown -R root:root ${D}
+}