meta-openembedded: subtree update:19528ba2a6..ef1b17f4ef

Callaghan, Dan (1):
      lmsensors: add a PACKAGECONFIG for sensord

Changqing Li (1):
      ntp: fix package split wrongly when enabled usrmerge

Khem Raj (1):
      remove spurious file

Nathan Rossi (3):
      libeigen: Add native and nativesdk to BBCLASSEXTEND
      python*-pyusb: Add native and nativesdk to BBCLASSEXTEND
      python*-pyserial: Add native and nativesdk to BBCLASSEXTEND

Oleksandr Kravchuk (23):
      babl: update to 0.1.62
      znc: update to 1.7.4
      zlog: update to 1.2.14
      wipe: update to 0.24
      upower: update to 0.99.11
      python-pyobject: update to 3.34.0
      python-pytoml: update to 0.1.21
      python-cpuset: update to 1.6
      libwebsockets: update to 3.2.0
      libvpx: update to 1.8.1
      libvdpau: update to 1.3
      libmicrohttpd: update to 0.9.66
      lcms: update to 2.9
      libblockdev: update to 2.23
      libbytesize: update to 2.1
      iwd: update to 0.20
      gsl: update to 2.6
      gflags: update to 2.2.2
      digitemp: update to 3.7.2
      catch2: update to 2.9.2
      botan: update to 2.11.0
      agent-proxy: update to 1.97
      ceres-solver: fix package version

Paul Eggleton (1):
      mosquitto: update to 1.6.5

Scott Ellis (1):
      wireguard: Upgrade 20190905 to 20190913

Trevor Gamblin (1):
      openjpeg: upgrade 2.3.0 -> 2.3.1

Yi Zhao (1):
      samba: upgrade 4.10.7 -> 4.10.8

Zang Ruochen (2):
      python-dbus: upgrade 1.2.10 -> 1.2.12
      python-pluggy: upgrade 0.12.0 -> 0.13.0

Zheng Ruoqin (1):
      xrdp: 0.9.4 -> 0.9.11

Change-Id: I3152060569cc5af7f7950c7037f25f54191d20a9
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.66.bb b/meta-openembedded/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.66.bb
new file mode 100644
index 0000000..7d349b9
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.66.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
+HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
+LICENSE = "LGPL-2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36"
+SECTION = "net"
+
+DEPENDS = "file"
+
+SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz"
+SRC_URI[md5sum] = "ce4050e75cc40d68506e2b403e1a76f9"
+SRC_URI[sha256sum] = "4e66d4db1574f4912fbd2690d10d227cc9cc56df6a10aa8f4fc2da75cea7ab1b"
+
+inherit autotools lib_package pkgconfig gettext
+
+CFLAGS += "-pthread -D_REENTRANT"
+
+EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
+
+PACKAGECONFIG ?= "curl https"
+PACKAGECONFIG_append_class-target = "\
+        ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \
+"
+PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
+PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
+PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls,"
+
+do_compile_append() {
+    sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
+}