meta-phosphor: add vardeps for HOST and CHASSIS instances
If a system were to change the OBMC_HOST_INSTANCES or
OBMC_CHASSIS_INSTANCES, many packages (incorrectly) do not get rebuilt.
This is because the variables are evaluated within Python contexts and
are not manually specified in the `vardeps`. Add as necessary.
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I84651a1a85a5c977be674d8b26b6e43e5ab46850
diff --git a/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb b/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
index 6c8f8ee..2a67b77 100644
--- a/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
@@ -13,6 +13,7 @@
START_INSTFMT = "op-start-host@{0}.service"
START_FMT = "../${START_TMPL}:${START_TGTFMT}.requires/${START_INSTFMT}"
SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK[vardeps] += "OBMC_HOST_INSTANCES OBMC_CHASSIS_INSTANCES"
inherit skeleton-gdbus
inherit obmc-phosphor-dbus-service