meta-phosphor: Fix build error for btrfs-tools-native
Building the native version of btrfs-tools is set by 'WKS_FILE_DEPENDS_DEFAULT'
at meta/classes-recipe/image_types_wic.bbclass.
Tested:
This fixes this build issue:
"ERROR: btrfs-tools-native-6.7.1-r0 do_configure: configure failed"
Change-Id: Ibeba207c0bdc2b1a545a91464134f10fbef2d764
Signed-off-by: Lean Sheng Tan <sheng.tan@9elements.com>
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
diff --git a/meta-phosphor/recipes-devtools/btrfs-tools/btrfs-tools_%.bbappend b/meta-phosphor/recipes-devtools/btrfs-tools/btrfs-tools_%.bbappend
index a5ebbcc..1ec223b 100644
--- a/meta-phosphor/recipes-devtools/btrfs-tools/btrfs-tools_%.bbappend
+++ b/meta-phosphor/recipes-devtools/btrfs-tools/btrfs-tools_%.bbappend
@@ -1,3 +1,10 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+# We want to remove the python support from the target package so that we do
+# not end up with a python dependency on the flash image.
PACKAGECONFIG:remove:class-target = "python"
+
+# There is an issue with the upstream `inherit_defer` ordering where a
+# `class-target` gets applied to the inherit portion, even for a native target.
+# See https://lore.kernel.org/openembedded-core/1bb12e6054301a5d3390991e1d1f0e013036a816.camel@linuxfoundation.org/
+PACKAGECONFIG:remove:class-native = "python"