meta-hxt: add soc update script
Add a simple script to help update the soc(host) firmware by flashcp.
Usage:
Format: socupdate.sh FileName IP
Example: socupdate.sh 0ACJAXXX.ROM 192.168.1.1
(From meta-hxt rev: 5679e42877a21303207011a2f8ec3e643b5e76b2)
Change-Id: I44da894bdbe048c7a79ec30bedd006918e1ae2d2
Signed-off-by: Yuan Yao <yao.yuan@hxt-semitech.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/socupdate/socupdate.bb b/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/socupdate/socupdate.bb
new file mode 100644
index 0000000..e2ae60a
--- /dev/null
+++ b/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/socupdate/socupdate.bb
@@ -0,0 +1,13 @@
+SUMMARY = "HXT SOC update"
+DESCRIPTION = "A sample script to help update the host(soc) firmware"
+HOMEPAGE = ""
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${HXTBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+SRC_URI += "file://socupdate.sh"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/socupdate.sh ${D}${bindir}/socupdate.sh
+}