poky: subtree update:b5763b2f48..f468a73523
Adrian Bunk (13):
iproute2: Remove -fcommon
libxcrypt2: Remove -fcommon
xorg-xserver: Remove -fcommon
mesa: Remove -fcommon
at-spi2-atk: Remove -fcommon
menu-cache: Replace -fcommon with fix
matchbox-wm: Replace -fcommon with fix
llvm: Remove -fcommon
vte: Remove workaround for gcc 4.8
python-numpy: Remove workaround for host gcc < 5
libtasn1: Remove workaround for host gcc < 5
nettle: Remove workaround for gcc < 5
wireless-regdb: Upgrade 2019.06.03 -> 2020.04.29
Alejandro Hernandez (1):
connman: Include vpn-script in FILES
Alexander Kanavin (30):
libinput: add ptest
libinput: update 1.15.2 -> 1.15.5
avahi: merge avahi-ui into the main recipe
avahi: update to 0.8
testsdkext/devtool: initialize the test component's git repo
git: update to 2.26.2
libcap: update to 2.33
libhandy: add a recipe from meta-oe
libdazzle: update to 3.36.0
epiphany: update to 3.36.1
patchelf: switch to git
powertop: switch to Arjan's git
meson: fix upstream version check
rpcsvc-proto: update to 1.4.1
vulkan-headers: upgrade 1.1.126.0 -> 1.2.135.0
vulkan-loader: upgrade 1.1.126.0 -> 1.2.135.0
vulkan-tools: upgrade 1.1.126.0 -> 1.2.135.0
vulkan-demos: upgrade to latest revision
e2fsprogs: update to 1.45.6
build-compare: update to latest revision
ovmf: update to 202002
cdrtools-native: fix upstream version check
re2c: correct upstream location
vte: add icu dependency
mesa: enable x11 for native/nativesdk
runqemu: set host DRI driver path for all instances of virgl usage
libepoxy: do not strip RUNPATH from native/nativesdk
virgl: skip test on Debian 9
runqemu: force software x11 renderer for SDL when GL is not in use
gcr: correct a build race between vapi files
Andrej Valek (1):
icu: upgrade 66.1 -> 67.1
Anton Eliasson (1):
meson.bbclass: Close the log file after reading
Bartosz Golaszewski (1):
busybox: disable i2ctransfer
Changqing Li (2):
rpm: fix file conflicts for MIPS64 N32
lib/oe/package_manager: update default rpm config %_prefer_color
Jacob Kroon (1):
pseudo: Fix enum typedef
Joe Slater (1):
wget: improve reproducible build
Joshua Watt (3):
libnewt: Backport patch to fix reproducibility
bitbake.conf: Prevent git from detecting parent repo in recipe
classes/kernel: Generate reproducible kernel module tarball
Kai Kang (1):
python3-git: 3.0.5 -> 3.1.2
Khem Raj (9):
avahi: Cover gtk packageconfig with x11/wayland distro features
tunes: Add new tune files for cortexa55 and cortexa73-cortexa53
gcc-runtime: Avoid march conflicts with newer cortex-a55 CPUs
gcc10: Update to GCC 10.1 Release
glibc: Update to latest on 2.31 branch
gcc10: Default back to -fcommon
gcc10: Revert using __getauxval in libgcc
glib-2.0: Fix stpcpy detection for mingw
wayland: fix condition for strndup detection
Konrad Weihmann (2):
pypi.bbclass: mind package suffix on version check
file: add PACKAGECONFIG for auto options
Mingli Yu (1):
python3-setuptools: add the missing rdepends
Peter Kjellerstedt (2):
sstate.bbclass: Do not fail if files cannot be touched
file: Remove unneccessary override of PACKAGECONFIG for native
Pierre-Jean Texier (1):
sysklogd: upgrade 2.1.1 -> 2.1.2
Richard Leitner (6):
gdbm: add patch to fix link failure against gcc 10
dtc: update to 1.6.0
libtirpc: remove extra "-fcommon" from CFLAGS
libcomps: update to 0.1.15
binutils: add patch to fix issues with gcc 10
cpio: add patch to fix issues with gcc 10
Richard Purdie (4):
recipes: Remove remaining INC_PR variables
insane: Promote warnings into errors
poky: We now match OE-Core's error/warning config so simplify
poky.conf: Post release version bump
Robert P. J. Day (1):
documentation.conf: Add variables supported by features_check.bbclass
Tim Orling (1):
pypi.bbclass: use new pypi UPSTREAM_CHECK_URI
Wang Mingyu (1):
nettle: upgrade 3.5.1 -> 3.6
Yeoh Ee Peng (1):
selftest/imagefeatures: Enable sanity test for IMAGE_GEN_DEBUGFS
Yi Zhao (1):
opkg-keyrings: check if opkg-key exists before run postinst
Zoltan Boszormenyi (4):
libva: Factor out base parts into an include file
libva-initial: New bootstrap recipe
mesa: Add PACKAGECONFIG knob to enable VAAPI
mesa: Add PACKAGECONFIG knob to enable VDPAU state tracker and drivers
jan (1):
scripts/tiny/ksize: Fix for more recent kernels
wenlin.kang@windriver.com (1):
populate_sdk_base.bbclass: fix warning: name not matched
Change-Id: Icd73153270a6cb7ab63257211350aa564867c2db
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/poky/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.45.6.bb b/poky/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.45.6.bb
new file mode 100644
index 0000000..4ad5b03
--- /dev/null
+++ b/poky/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.45.6.bb
@@ -0,0 +1,140 @@
+require e2fsprogs.inc
+
+SRC_URI += "file://remove.ldconfig.call.patch \
+ file://run-ptest \
+ file://ptest.patch \
+ file://mkdir_p.patch \
+ file://0001-configure.ac-correct-AM_GNU_GETTEXT.patch \
+ file://0001-intl-do-not-try-to-use-gettext-defines-that-no-longe.patch \
+ "
+
+SRC_URI_append_class-native = " file://e2fsprogs-fix-missing-check-for-permission-denied.patch \
+ file://quiet-debugfs.patch \
+"
+
+SRCREV = "506d96fe640f76ab04276e0a7c578aa108ce19f8"
+UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+\.\d+(\.\d+)*)$"
+
+EXTRA_OECONF += "--libdir=${base_libdir} --sbindir=${base_sbindir} \
+ --enable-elf-shlibs --disable-libuuid --disable-uuidd \
+ --disable-libblkid --enable-verbose-makecmds \
+ --with-crond-dir=no"
+
+EXTRA_OECONF_darwin = "--libdir=${base_libdir} --sbindir=${base_sbindir} --enable-bsd-shlibs"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[fuse] = '--enable-fuse2fs,--disable-fuse2fs,fuse'
+
+# make locale rules sometimes fire, sometimes don't as git doesn't preserve
+# file mktime. Touch the files introducing non-determinism to the build
+do_compile_prepend (){
+ find ${S}/po -type f -name "*.po" -exec touch {} +
+}
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ oe_runmake 'DESTDIR=${D}' install-libs
+ # We use blkid from util-linux now so remove from here
+ rm -f ${D}${base_libdir}/libblkid*
+ rm -rf ${D}${includedir}/blkid
+ rm -f ${D}${base_libdir}/pkgconfig/blkid.pc
+ rm -f ${D}${base_sbindir}/blkid
+ rm -f ${D}${base_sbindir}/fsck
+ rm -f ${D}${base_sbindir}/findfs
+
+ # e2initrd_helper and the pkgconfig files belong in libdir
+ if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
+ install -d ${D}${libdir}
+ mv ${D}${base_libdir}/e2initrd_helper ${D}${libdir}
+ mv ${D}${base_libdir}/pkgconfig ${D}${libdir}
+ fi
+
+ oe_multilib_header ext2fs/ext2_types.h
+ install -d ${D}${base_bindir}
+ mv ${D}${bindir}/chattr ${D}${base_bindir}/chattr.e2fsprogs
+
+ install -v -m 755 ${S}/contrib/populate-extfs.sh ${D}${base_sbindir}/
+
+ # Clean host path (build directory) in compile_et, mk_cmds
+ sed -i -e "s,\(ET_DIR=.*\)${S}/lib/et\(.*\),\1${datadir}/et\2,g" ${D}${bindir}/compile_et
+ sed -i -e "s,\(SS_DIR=.*\)${S}/lib/ss\(.*\),\1${datadir}/ss\2,g" ${D}${bindir}/mk_cmds
+}
+
+# Need to find the right mke2fs.conf file
+e2fsprogs_conf_fixup () {
+ for i in mke2fs mkfs.ext2 mkfs.ext3 mkfs.ext4; do
+ create_wrapper ${D}${base_sbindir}/$i MKE2FS_CONFIG=${sysconfdir}/mke2fs.conf
+ done
+}
+
+do_install_append_class-native() {
+ e2fsprogs_conf_fixup
+}
+
+do_install_append_class-nativesdk() {
+ e2fsprogs_conf_fixup
+}
+
+do_install_append_class-target() {
+ mv ${D}${base_sbindir}/mke2fs ${D}${base_sbindir}/mke2fs.e2fsprogs
+ mv ${D}${base_sbindir}/mkfs.ext2 ${D}${base_sbindir}/mkfs.ext2.e2fsprogs
+ mv ${D}${base_sbindir}/tune2fs ${D}${base_sbindir}/tune2fs.e2fsprogs
+}
+
+RDEPENDS_e2fsprogs = "e2fsprogs-badblocks e2fsprogs-dumpe2fs"
+RRECOMMENDS_e2fsprogs = "e2fsprogs-mke2fs e2fsprogs-e2fsck"
+
+PACKAGES =+ "e2fsprogs-badblocks e2fsprogs-dumpe2fs e2fsprogs-e2fsck e2fsprogs-e2scrub e2fsprogs-mke2fs e2fsprogs-resize2fs e2fsprogs-tune2fs"
+PACKAGES =+ "libcomerr libss libe2p libext2fs"
+
+FILES_e2fsprogs-dumpe2fs = "${base_sbindir}/dumpe2fs"
+FILES_e2fsprogs-resize2fs = "${base_sbindir}/resize2fs*"
+FILES_e2fsprogs-e2fsck = "${base_sbindir}/e2fsck ${base_sbindir}/fsck.ext*"
+FILES_e2fsprogs-e2scrub = "${base_sbindir}/e2scrub*"
+FILES_e2fsprogs-mke2fs = "${base_sbindir}/mke2fs.e2fsprogs ${base_sbindir}/mkfs.ext* ${sysconfdir}/mke2fs.conf"
+FILES_e2fsprogs-tune2fs = "${base_sbindir}/tune2fs.e2fsprogs ${base_sbindir}/e2label"
+FILES_e2fsprogs-badblocks = "${base_sbindir}/badblocks"
+FILES_libcomerr = "${base_libdir}/libcom_err.so.*"
+FILES_libss = "${base_libdir}/libss.so.*"
+FILES_libe2p = "${base_libdir}/libe2p.so.*"
+FILES_libext2fs = "${libdir}/e2initrd_helper ${base_libdir}/libext2fs.so.*"
+FILES_${PN}-dev += "${datadir}/*/*.awk ${datadir}/*/*.sed ${base_libdir}/*.so ${bindir}/compile_et ${bindir}/mk_cmds"
+
+ALTERNATIVE_${PN} = "chattr"
+ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_LINK_NAME[chattr] = "${base_bindir}/chattr"
+ALTERNATIVE_TARGET[chattr] = "${base_bindir}/chattr.e2fsprogs"
+
+ALTERNATIVE_${PN}-doc = "fsck.8"
+ALTERNATIVE_LINK_NAME[fsck.8] = "${mandir}/man8/fsck.8"
+
+ALTERNATIVE_${PN}-mke2fs = "mke2fs mkfs.ext2"
+ALTERNATIVE_LINK_NAME[mke2fs] = "${base_sbindir}/mke2fs"
+ALTERNATIVE_LINK_NAME[mkfs.ext2] = "${base_sbindir}/mkfs.ext2"
+
+ALTERNATIVE_${PN}-tune2fs = "tune2fs"
+ALTERNATIVE_LINK_NAME[tune2fs] = "${base_sbindir}/tune2fs"
+
+RDEPENDS_e2fsprogs-e2scrub = "bash"
+RDEPENDS_${PN}-ptest += "coreutils procps bash bzip2 diffutils perl sed"
+RDEPENDS_${PN}-ptest += "e2fsprogs-badblocks e2fsprogs-dumpe2fs e2fsprogs-e2fsck e2fsprogs-mke2fs e2fsprogs-resize2fs e2fsprogs-tune2fs"
+
+do_compile_ptest() {
+ oe_runmake -C ${B}/tests
+}
+
+do_install_ptest() {
+ cp -R --no-dereference --preserve=mode,links -v ${B}/tests ${D}${PTEST_PATH}/test
+ cp -R --no-dereference --preserve=mode,links -v ${S}/tests/* ${D}${PTEST_PATH}/test
+ sed -e 's!../e2fsck/e2fsck!e2fsck!g' \
+ -e 's!../misc/tune2fs!tune2fs!g' -i ${D}${PTEST_PATH}/test/*/expect*
+ sed -e 's!../e2fsck/e2fsck!${base_sbindir}/e2fsck!g' -i ${D}${PTEST_PATH}/test/*/script
+
+ # Remove various files
+ find "${D}${PTEST_PATH}" -type f \
+ \( -name 'Makefile' -o -name 'Makefile.in' -o -name '*.o' -o -name '*.c' -o -name '*.h' \)\
+ -exec rm -f {} +
+
+ install -d ${D}${PTEST_PATH}/lib
+ install -m 0644 ${B}/lib/config.h ${D}${PTEST_PATH}/lib/
+}