meta-openembedded: subtree update:6a5d6bc9ad..3061ead8cf
Adrian Bunk (2):
gpsd: gpscat no longer uses python-curses in 3.19
dejagnu: Remove, moved to oe-core
Alex Kiernan (1):
zstd: Upgrade 1.4.2 -> 1.4.3
Alistair Francis (2):
python3-twine: Initial commit of 1.13.0
python3-pytest-asyncio: Initial commit of 0.10.0
Andreas Müller (4):
fluidsynth: upgrade 2.0.5 -> 2.0.6
imsettings: upgrade 1.7.3 -> 1.8.1 and rework recipe
xfce4-settings: upgrade 4.14.0 -> 4.14.1
xfce4-screenshooter: upgrade 1.9.5 -> 1.9.6
Andrej Valek (1):
nodejs: 10.16.2 -> 10.16.3
Changqing Li (7):
yail: update UPSTREAM_CHECK_GITTAGREGEX
iscsi-initiator-utils: 2.0.876 -> 2.0.877
postgresql: 11.4 -> 11.5
satyr: upgrade 0.27 -> 0.28
freeradius: upgrade 3.0.17 -> 3.0.19
drbd-utils: switch to add patch from change source in do_configure
xfsdump: support usrmerge
Gianfranco Costamagna (2):
grpc: don't use unexisting gettid function on glibc 2.29, it has been implemented only in 2.30
grpc: Change gettid patch with the upstream merged version
Hongxu Jia (1):
lvm2: fix blkdeactivate failed with command not found
Kai Kang (4):
lmbench: update script lmbench-run
mariadb: fix file conflictions when multilib enabled
php: sync with apache2's change
apache2: fix multilib file conflicts
Khem Raj (11):
iperf2: Fix build with latest libc++
iscsi-initiator-utils: Inherit pkgconfig and override PKG_CONFIG
klibc: Fix build with 5.2+ kernel headers
samba: Fix configure tests to work with clang
ltrace: Fix build on mips
python-jinja2: Make asyncio specific to python3 module alone
python3-cmd2: Add to blacklist
nodejs: Mark incompatible with risc-v
drbd,netkit-rusers: Blacklist packages
vboxguestdrivers,can-isotp,bpftool: Add to Blacklist
strongswan: Fix do_patch fuzz
Li Zhou (1):
tipcutils: ptts: Set recv buffer size to max to receive as many packets as possible
Martin Jansa (1):
python3-pyatspi: restrict with GTK2DISTROFEATURES
Oleksandr Kravchuk (1):
nano: update to 4.4
Qi.Chen@windriver.com (2):
python-hyperlink: rdepend on python-idna
python-jinja2: rdepend on asyncio module
Robert Yang (1):
netcf: Fix do_configure failed when multilib
Scott Ellis (1):
wireguard: Upgrade 20190702 to 20190905
Yuan Chao (10):
strongswan: upgrade 5.8.0 -> 5.8.1
php: upgrade 7.3.8 -> 7.3.9
libtalloc: upgrade 2.2.0 -> 2.3.0
numactl: upgrade 2.0.12 -> 2.0.13
uhubctl: upgrade 2.0.0 -> 2.1.0
python-pytest: upgrade 5.1.1 -> 5.1.2
python-stevedore: upgrade 1.30.1 -> 1.31.0
python-dbus: upgrade 1.2.8 -> 1.2.10
python-pbr: upgrade 5.4.2 -> 5.4.3
python-pyasn1: upgrade 0.4.6 -> 0.4.7
Zang Ruochen (3):
python-paste: upgrade 3.1.1 -> 3.2.0
libnet-dns-perl: upgrade 1.20 -> 1.21
hwdata: upgrade 0.326 -> 0.327
Zheng Ruoqin (1):
python-cmd2: Add python3 version
aehs29@gmail.com (1):
remmina: Add recipe for the remmina remote desktop client
Change-Id: I11f4319f53655ab389fcb7a0ce4f22b71f9a8da2
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.10.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.10.bb
new file mode 100644
index 0000000..9907ea9
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.10.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Python bindings for the DBus inter-process communication system"
+SECTION = "devel/python"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "MIT & AFL-2.1 | GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4 \
+ file://dbus-gmain/COPYING;md5=99fece6728a80737c8fd3e7c734c17c4 "
+DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
+"
+
+SRC_URI[md5sum] = "5d21d5ae6423f0e41caa3400af44edac"
+SRC_URI[sha256sum] = "d4332bbd4a0054fa4010b259c293b84d461bbd9d7a8ef528157d151c0398d886"
+S = "${WORKDIR}/dbus-python-${PV}"
+
+inherit distutils-base autotools pkgconfig
+
+# documentation needs python-sphinx, which is not in oe-core or meta-python for now
+# change to use PACKAGECONFIG when python-sphinx is added to oe-core or meta-python
+EXTRA_OECONF += "--disable-documentation"
+
+export STAGING_LIBDIR
+export STAGING_INCDIR
+
+RDEPENDS_${PN} = "python-io python-logging python-stringold python-threading python-xml"
+
+FILES_${PN}-dev += "${libdir}/pkgconfig"
+
+do_install_append() {
+ # Remove files that clash with python3-dbus; their content is same
+ rm ${D}${includedir}/dbus-1.0/dbus/dbus-python.h ${D}${libdir}/pkgconfig/dbus-python.pc
+}