subtree updates
poky: 50d272863d..0b3e371116:
Alistair Francis (1):
recipes-bsp/opensbi: Fix the u-boot payload name
Changqing Li (2):
update-rc.d: update SRCREV and license checksum
update-rc.d: support enable/disable options
Chen Qi (2):
context.py: avoid skipping tests by meaningless command argument
oeqa: avoid class setup method to run when skipping the whole class
Joe Slater (1):
glib-2.0: Fix CVE-2019-12450
Jonathan Rajotte (1):
lttng-tools: update to 2.10.7
Joseph Reynolds (1):
dropbear: new feature: disable-weak-ciphers
Joshua Watt (4):
perl: Improve ptest package reproducibility
python3: Reformat sysconfig
perl: Reproducible build fixes
bash: Remove .build files for reproducible builds
Martin Jansa (1):
gcc-runtime.inc: create the correct directory before creating the symlinks in it
Ricardo Ribalda Delgado (1):
go: avoid host contamination by GOCACHE
Ross Burton (1):
pigz: bump alternative priority
Tim Orling (1):
ptest-packagelists.inc: add libmodule-build-perl-ptest
meta-openembedded: 3b245e4fe8..64974b8779:
Adrian Bunk (9):
libauthen-radius-perl: Remove manual RDEPENDS from PN-ptest to PN package
network-manager-applet: Remove obsolete dbus-glib and libnm-glib dependencies
ndctl: Remove the unnecessary dependency on virtual/kernel
tipcutils: Remove the unnecessary dependency on virtual/kernel
xl2tpd: Remove the old 1.3.6 version
gpsd: Force using python-scons-native for now
efibootmgr: Remove, was moved to oe-core
efivar: Remove, was moved to oe-core
wireless-regdb: Remove, was moved to oe-core
Andrey Zhizhikin (1):
cpuburn-arm: add aarch64 machine and build configuration
Ankit Navik (1):
safec: Add Safe C license
Bartosz Golaszewski (1):
libgpiod: upgrade to v1.4
Hongxu Jia (1):
dracut: fix generated initramfs boot failure under bash 5
Kai Kang (1):
xfce4-screensaver: 0.1.4 -> 0.1.5
Khem Raj (5):
stressapptest: Fix build with libc++
stressapptest: Implement reading sysfs and use it if sysconf is not there
stressapptest: Use git SHA instead of git archive
gmime: Add recipe
pidgin-sipe: Depend on gmime
Maciej Pijanowski (1):
recipes-benchmark/stressapptest_1.0.9.bb: add recipe
Mingli Yu (3):
mariadb: Upgrade to 10.3.16
mozjs: Fix do_patch error for mips64-n32
python-lxml: replace -Og with -O for mips64-32
Naveen Saini (1):
pm-graph: fix multilib build failure
Nicola Lunghi (1):
libp11: No need to delete *.la anymore
Oleksandr Kravchuk (1):
openconnect: update to 8.03
Pascal Bach (3):
protobuf: 3.6.1 -> 3.8.0
protobuf-c: add patch for protobuf 3 compatibility
python3-protobuf, python-protobuf: 3.6.1 -> 3.8.0
Persian Prince (1):
blueman_%.bbappend: Avoid PAK archive (application/x-pak)
Saikiran Madugula (1):
gitver: Pass git directory argument to gitrev_run
Tim Orling (1):
libmodule-build-perl: drop, has moved to oe-core
Yi Zhao (1):
snort: upgrade 2.9.11.1 -> 2.9.13
Zang Ruochen (3):
python-twisted: upgrade 19.2.0 -> 19.2.1
python-wrapt: upgrade 1.11.1 -> 1.11.2
python-certifi: upgrade 2019.3.9 -> 2019.6.16
Change-Id: I0c3385628e0382c56c94fa27ba4d14e301c2e558
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb b/meta-openembedded/meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb
new file mode 100644
index 0000000..ec36a37
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Open client for Cisco AnyConnect VPN"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=243b725d71bb5df4a1e5920b344b86ad"
+
+SRC_URI = "git://git.infradead.org/users/dwmw2/openconnect.git"
+SRCREV = "ea73851969ae7a6ea54fdd2d2b8c94776af24b2a"
+
+DEPENDS = "vpnc libxml2 krb5 gettext-native"
+RDEPENDS_${PN} = "bash python"
+
+PACKAGECONFIG ??= "gnutls lz4 libproxy"
+
+# config defaults
+PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls,"
+PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4,"
+PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy,"
+
+# not config defaults
+PACKAGECONFIG[pcsc-lite] = "--with-libpcsclite,--without-libpcsclite,pcsc-lite,"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--with-vpnc-script=${SYSROOT_DESTDIR}${sysconfdir}/vpnc/vpnc-script \
+ --disable-static"
+
+do_configure_append() {
+ # script has /usr/bin/python2 path hardcoded
+ sed -i -e 's=python2\.*=python=g' ${S}/trojans/tncc-wrapper.py
+}