phosphor-led-manager: automatically deduce use-{json,yaml}
New systems should be using the 'use-json' model by default, but it
currently requires a bbappend in order to enable it. Automatically
detect based on the PREFERRED_PROVIDER of virtual/...-config-native if
the intended use is JSON or YAML.
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Ie674d1b901395b4fd41838b6e978ca1ff00b0277
diff --git a/meta-ibm/recipes-phosphor/leds/phosphor-led-manager_%.bbappend b/meta-ibm/recipes-phosphor/leds/phosphor-led-manager_%.bbappend
index 8001095..b3bfaa4 100644
--- a/meta-ibm/recipes-phosphor/leds/phosphor-led-manager_%.bbappend
+++ b/meta-ibm/recipes-phosphor/leds/phosphor-led-manager_%.bbappend
@@ -8,7 +8,7 @@
# Use the JSON configuration file at runtime than the static led.yaml
# Also, enable Lamp Test and OperationalStatus monitor feature for
# p10bmc systems
-PACKAGECONFIG:append:p10bmc = " use-json use-lamp-test monitor-operational-status"
+PACKAGECONFIG:append:p10bmc = " use-lamp-test monitor-operational-status"
# Install the lamp test override file for p10bmc
SRC_URI:append:p10bmc = " file://lamp-test-led-overrides.json"