meta-ibm: p10bmc-distributed: enable etcd package
This feature helps to support a system where multiple
BMC's will be a part of a single composed system.
etcd is a strongly consistent, distributed key-value store
that provides a reliable way to store data that needs to be
accessed by a distributed system or cluster of machines.
Enabled "etcd" package to install etcd binaries and
the required systemd units to start etcd in cluster configuration.
Tested: verified image.
Installed binaries and systemd unit files.
rootfs/etc/etcd.d/etcd-existing.conf
rootfs/etc/etcd-new.conf.sample
rootfs/etc/systemd/system/multi-user.target.wants/etcd-new.service
rootfs/etc/systemd/system/multi-user.target.wants/etcd.service
rootfs/lib/systemd/system/etcd-new.service
rootfs/lib/systemd/system/etcd.service
rootfs/usr/bin/etcd
rootfs/usr/bin/etcdctl
Change-Id: Iad30df3475b861491492168f975d7b347a1481a6
Signed-off-by: ojayanth <ojayanth@in.ibm.com>
diff --git a/meta-ibm/recipes-phosphor/images/obmc-phosphor-image.bbappend b/meta-ibm/recipes-phosphor/images/obmc-phosphor-image.bbappend
index 71e8580..92fa44a 100644
--- a/meta-ibm/recipes-phosphor/images/obmc-phosphor-image.bbappend
+++ b/meta-ibm/recipes-phosphor/images/obmc-phosphor-image.bbappend
@@ -1,6 +1,7 @@
OBMC_IMAGE_EXTRA_INSTALL:append:ibm-ac-server = " mboxd max31785-msl phosphor-msl-verify liberation-fonts uart-render-controller first-boot-set-hostname"
OBMC_IMAGE_EXTRA_INSTALL:remove:witherspoon-tacoma = " liberation-fonts uart-render-controller"
OBMC_IMAGE_EXTRA_INSTALL:append:p10bmc = " mboxd"
+OBMC_IMAGE_EXTRA_INSTALL:append:p10bmc-distributed = " etcd"
IMAGE_FEATURES:append = " obmc-dbus-monitor"