meta-facebook: reduce permissions on scripts

Scripts should be installed with 0755 permissions and not 0777,
otherwise non-root users can potentially modify or delete them.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I41270a2bb3fb940d8ca49ed6230545d98efb2fea
diff --git a/meta-facebook/recipes-phosphor/datetime/phosphor-time-manager_%.bbappend b/meta-facebook/recipes-phosphor/datetime/phosphor-time-manager_%.bbappend
index 278f7b6..9170cf8 100644
--- a/meta-facebook/recipes-phosphor/datetime/phosphor-time-manager_%.bbappend
+++ b/meta-facebook/recipes-phosphor/datetime/phosphor-time-manager_%.bbappend
@@ -13,7 +13,7 @@
     install -d ${D}$/lib/systemd/system
     install -m 0644 ${WORKDIR}/bmc-set-time.service  ${D}$/lib/systemd/system
     install -d ${D}${libexecdir}
-    install -m 0777 ${WORKDIR}/set-bmc-time-from-host ${D}${libexecdir}
+    install -m 0755 ${WORKDIR}/set-bmc-time-from-host ${D}${libexecdir}
 }
 
 SYSTEMD_SERVICE:${PN}:fb-withhost += "bmc-set-time.service"