phal: Enabled service to reinit CEC device tree

The POWER CEC system device tree need reinitialize before doing
normal ipl to mark required targets as functional for ipling.

The service file is added in below patch.
https://gerrit.openbmc-project.xyz/c/openbmc/openpower-proc-control/+/36577

(From meta-openpower rev: 2257014de9964f673b4ae2864deffd25e6022cee)

Signed-off-by: Ramesh Iyyar <rameshi1@in.ibm.com>
Change-Id: I499ee3c6c2b4f3caf33609ca6e70112801d5cbae
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index f197c39..1ca607b 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -11,7 +11,7 @@
 inherit systemd
 
 SRC_URI += "git://github.com/openbmc/openpower-proc-control"
-SRCREV = "e62ca93360e34b4e59ab57b0c0b46221dec61cab"
+SRCREV = "b20593f88b7cb88844363f8475669dad16e88afb"
 
 DEPENDS += " \
         autoconf-archive-native \
@@ -36,4 +36,5 @@
                          ${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'set-spi-mux.service', '', d)} \
                          op-continue-mpreboot@.service \
                          op-enter-mpreboot@.service \
+                         ${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'phal-reinit-devtree.service', '', d)} \
                          "