etcd-cpp-apiv3: bring in needed boost libraries
If a system owner is bringing in the new etcd feature then they are
required to pick up some additional boost dependencies.
Change-Id: I6dfe71fbaf496b5f4a278fac55e2dfa68b630a11
Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com>
diff --git a/meta-phosphor/recipes-support/boost/boost_%.bbappend b/meta-phosphor/recipes-support/boost/boost_%.bbappend
index eb16aca..cde1a47 100644
--- a/meta-phosphor/recipes-support/boost/boost_%.bbappend
+++ b/meta-phosphor/recipes-support/boost/boost_%.bbappend
@@ -11,3 +11,6 @@
#https://github.com/openbmc/docs/blob/master/cpp-style-and-conventions.md#boost
#
BOOST_LIBS:openbmc-phosphor:class-target = "chrono thread context coroutine"
+
+BOOST_LIBS:openbmc-phosphor:class-target:append:df-etcd = " \
+ random system filesystem atomic date_time regex"