meta-ibm: Add a chrony configuration file
The huygens machine is based on the new pstbmc machine family from IBM.
It will be our first redundant BMC system [1]. This new system expects
to have chrony daemon to run along with the existing systemd-
timesyncd deamon.
The commit adds a custom chrony configuration file in order to
achieve syncing of time between redundant BMCs.
[1]: https://gerrit.openbmc.org/c/openbmc/docs/+/70233
Tested: Configuration file is updated.
Change-Id: I6fb6787055bdfc423ef439c43b9c17db679d062f
Signed-off-by: Pavithra Barithaya <pavithrabarithaya07@gmail.com>
diff --git a/meta-ibm/recipes-support/chrony/chrony_%.bbappend b/meta-ibm/recipes-support/chrony/chrony_%.bbappend
index d32a79d..1e88511 100644
--- a/meta-ibm/recipes-support/chrony/chrony_%.bbappend
+++ b/meta-ibm/recipes-support/chrony/chrony_%.bbappend
@@ -2,9 +2,11 @@
install_chrony_configuration() {
install -D -m 0644 ${WORKDIR}/chronyd.service ${D}${systemd_system_unitdir}/chronyd.service
+ install -m 644 -D ${WORKDIR}/chrony.conf ${D}${sysconfdir}/chrony.conf
}
SRC_URI:append:df-chrony = " file://chronyd.service"
+SRC_URI:append:df-chrony = " file://chrony.conf"
do_install:append:huygens() {
install_chrony_configuration
}