poky: sumo refresh 64a257fa22..fa962ec72f
Update poky to sumo HEAD.
Anuj Mittal (1):
linux-yocto: update genericx86* SRCREV for 4.14
Martin Hundebøll (2):
shadow: improve reproducibility by hard-coding shell path
busybox: make busybox.links.{suid, nosuid} reproducible
Paul Eggleton (1):
socat: fix LICENSE
Richard Purdie (10):
sanity: Add check for WSL
poky.conf: Update the distros we test against on the autobuilder
poky.conf: Bump version for 2.5.2 sumo release
build-appliance-image: Update to sumo head revision
bitbake: server/process: Fix unclosed socket warnings upon server connection refused
bitbake: lib/bb/server: Avoid UnboundLocalError traceback
bitbake: server/process: Fix ConnectionRefusedError tracebacks
bitbake: runqueue: Ensure disk monitor is started when no setscene tasks are run
bitbake: process: Flush key output to logs
bitbake: main: Don't use print() directly, use logger
Change-Id: Ie14695232a8adecd2013d629208da320963532ce
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/poky/meta/classes/sanity.bbclass b/poky/meta/classes/sanity.bbclass
index 4e8eae8..374dacf 100644
--- a/poky/meta/classes/sanity.bbclass
+++ b/poky/meta/classes/sanity.bbclass
@@ -511,6 +511,16 @@
return None
+# Check if we're running on WSL (Windows Subsystem for Linux). Its known not to
+# work but we should tell the user that upfront.
+def check_wsl(d):
+ with open("/proc/version", "r") as f:
+ verdata = f.readlines()
+ for l in verdata:
+ if "Microsoft" in l:
+ return "OpenEmbedded doesn't work under WSL at this time, sorry"
+ return None
+
# Tar version 1.24 and onwards handle overwriting symlinks correctly
# but earlier versions do not; this needs to work properly for sstate
def check_tar_version(sanity_data):
@@ -625,6 +635,7 @@
status.addresult(check_tar_version(d))
status.addresult(check_git_version(d))
status.addresult(check_perl_modules(d))
+ status.addresult(check_wsl(d))
missing = ""