meta-nuvoton: images: fixup bingo and bootblock recipes
Add version information and descriptions to the two recipe files.
(From meta-nuvoton rev: b5087ace68e81084e16075e76659ca5a6f553994)
Change-Id: I52db4fc4193999b01a4a17e78d9060ef93eab944
Signed-off-by: Benjamin Fair <benjaminfair@google.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.09.05.bb b/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.09.05.bb
new file mode 100644
index 0000000..7c847f2
--- /dev/null
+++ b/meta-nuvoton/recipes-bsp/images/npcm7xx-bootblock_10.09.05.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Primary bootloader for NPCM7XX (Poleg) devices"
+DESCRIPTION = "Primary bootloader for NPCM7XX (Poleg) devices"
+HOMEPAGE = "https://github.com/Nuvoton-Israel/npcm7xx-bootblock"
+LICENSE = "CLOSED"
+LIC_FILES_CHKSUM = ""
+
+SRCREV = "${PV}"
+FILENAME = "Poleg_bootblock.bin"
+
+SRC_URI = "git://github.com/Nuvoton-Israel/npcm7xx-bootblock;protocol=git"
+SRC_URI[md5sum] = "cf8daa5f4636ed1ff952618e435af028"
+
+S = "${WORKDIR}/git"
+
+inherit deploy
+
+do_deploy () {
+ install -d ${DEPLOYDIR}
+ install -m 644 ${FILENAME} ${DEPLOYDIR}/
+}
+
+addtask deploy before do_build after do_compile