meta-google: avahi: Restrict settings to machine interface
We don't want this to run on external interfaces, so we limit avahi to
the internal interface only.
Google-Bug-Id: 166192295
Change-Id: Ifc056baab670d3c09aaba7256041777aa7bff6e3
Signed-off-by: William A. Kennington III <wak@google.com>
diff --git a/meta-google/recipes-connectivity/avahi/avahi_%.bbappend b/meta-google/recipes-connectivity/avahi/avahi_%.bbappend
new file mode 100644
index 0000000..8fb53d3
--- /dev/null
+++ b/meta-google/recipes-connectivity/avahi/avahi_%.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_prepend_gbmc := "${THISDIR}/files:"
+SRC_URI_append_gbmc = " file://avahi-daemon.conf"
+do_install_append_gbmc() {
+ install -m0644 ${WORKDIR}/avahi-daemon.conf ${D}${sysconfdir}/avahi/
+}