Update u-boot to support booting FIT images
This adds FIT support from Rick.
Two of the patches are only relevant to our out-of-tree Aspeed support,
but one was sent upstream. There is also a bugfix for a linker issue
discovered when preparing this release that was sent upstream.
Bugfix for building with bleeding edge binutils
* Makefile: Fix linking with modern binutils (sent upstream[1])
FIT image support
* Enable FIT image support and FDT loading for AST2400/AST2500
* bootm: relocate ramdisk if CONFIG_SYS_BOOT_RAMDISK_HIGH set (sent
upstream [2])
* aspeed: remove hack loading ramdisk in memory
[1] https://patchwork.ozlabs.org/patch/706336/
[2] https://patchwork.ozlabs.org/patch/704192/
Change-Id: I46469bb0426c1071843884a3b4f1e15e3d6a58e0
Signed-off-by: Joel Stanley <joel@jms.id.au>
diff --git a/meta-phosphor/common/recipes-bsp/u-boot/u-boot-fw-utils_2016.07.bb b/meta-phosphor/common/recipes-bsp/u-boot/u-boot-fw-utils_2016.07.bb
index eb89efc..034f8c1 100644
--- a/meta-phosphor/common/recipes-bsp/u-boot/u-boot-fw-utils_2016.07.bb
+++ b/meta-phosphor/common/recipes-bsp/u-boot/u-boot-fw-utils_2016.07.bb
@@ -4,7 +4,7 @@
SECTION = "bootloader"
DEPENDS = "mtd-utils"
-SRCREV = "f9b2a49f57c153c7358f9769234c0cefdf4de8d4"
+SRCREV = "aa7a90f2ff1e807e057c6dbb0d0c579174c75acc"
UBRANCH = "v2016.07-aspeed-openbmc"
SRC_URI = "git://git@github.com/openbmc/u-boot.git;branch=${UBRANCH};protocol=https"