pldm: Add function2 dependency

PLDM is adding infrastructure to register callbacks for the PLDM
requester code.

https://gerrit.openbmc-project.xyz/c/openbmc/pldm/+/43465

function2 is header only and already leveraged in sdeventplus and
phosphor-ipmi-flash. function 2 provides move-only
fu2::unique_function.

Using function2 had an image size increase of 4K for PLDM daemon
with build-type minsize.

Signed-off-by: Tom Joseph <rushtotom@gmail.com>
Change-Id: I427219b51cee7b29b7e62cc77d597143f21fcda0
diff --git a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
index 1c07ad5..44e42fb 100644
--- a/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
+++ b/meta-phosphor/recipes-phosphor/pldm/pldm_git.bb
@@ -8,6 +8,7 @@
 
 require pldm.inc
 
+DEPENDS += "function2"
 DEPENDS += "systemd"
 DEPENDS += "sdeventplus"
 DEPENDS += "phosphor-dbus-interfaces"