phosphor-hostfw-image: Fix destination directory
The way the destination directory was specified it was causing the
recursive copy to create a duplicate subdirectory image/image/ and
update/update/. There's no need to specify the destination directory.
Also remove the prepend from the compile function per review
comments on the original commit that created this recipe.
(From meta-phosphor rev: bd747f6d30cb7ff2d845e79345bd9868a774c803)
Change-Id: Iec45415346cc8caead9659ab39eb02f91c90d31f
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-phosphor/flash/phosphor-hostfw-image.bb b/meta-phosphor/recipes-phosphor/flash/phosphor-hostfw-image.bb
index 5663771..a9123b1 100644
--- a/meta-phosphor/recipes-phosphor/flash/phosphor-hostfw-image.bb
+++ b/meta-phosphor/recipes-phosphor/flash/phosphor-hostfw-image.bb
@@ -11,7 +11,7 @@
LICENSE = "${HOSTFW_LICENSE}"
LIC_FILES_CHKSUM = "${HOSTFW_LIC_FILES_CHKSUM}"
-do_compile_prepend() {
+do_compile() {
# The image directory can be used as the source to create a filesystem to
# add to the BMC image.
install -d ${B}/image
@@ -24,8 +24,8 @@
do_deploy() {
install -d ${DEPLOYDIR}/hostfw/image
install -d ${DEPLOYDIR}/hostfw/update
- cp -R --no-dereference --preserve=mode,links ${B}/image/ ${DEPLOYDIR}/hostfw/image/
- cp -R --no-dereference --preserve=mode,links ${B}/update/ ${DEPLOYDIR}/hostfw/update/
+ cp -R --no-dereference --preserve=mode,links ${B}/image/ ${DEPLOYDIR}/hostfw/
+ cp -R --no-dereference --preserve=mode,links ${B}/update/ ${DEPLOYDIR}/hostfw/
}
addtask deploy before do_build after do_compile