meta-ampere: Cleanup for Yocto override syntax change

Run convert-overrides.py meta-ampere and update missing changes as
below:
- Change all _mtjade to :mtjade
- Change all _${PN} to :${PN}

Tested:
1. Check compilation without problem.
2. Check basic functions like switch UART mux, power control.

Signed-off-by: Thang Q. Nguyen <thang@os.amperecomputing.com>
Change-Id: I42038b2a98ed1951d6c770bdf49f5fc440f8163e
diff --git a/meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb b/meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb
index c19cdee..c1a616a 100644
--- a/meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb
+++ b/meta-ampere/meta-jade/recipes-phosphor/gpio/id-button.bb
@@ -6,7 +6,7 @@
 inherit obmc-phosphor-systemd
 
 DEPENDS += "virtual/obmc-gpio-monitor"
-RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
+RDEPENDS:${PN} += "virtual/obmc-gpio-monitor"
 
 SRC_URI += "file://toggle_identify_led.sh"
 
@@ -16,7 +16,7 @@
             ${D}${bindir}/toggle_identify_led.sh
 }
 
-SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/id_button"
+SYSTEMD_ENVIRONMENT_FILE:${PN} +="obmc/gpio/id_button"
 
 ID_BUTTON_SERVICE = "id_button"
 
@@ -25,5 +25,5 @@
 TGT = "multi-user.target"
 FMT = "../${TMPL}:${TGT}.requires/${INSTFMT}"
 
-SYSTEMD_SERVICE_${PN} += "id-button-pressed.service"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'ID_BUTTON_SERVICE')}"
+SYSTEMD_SERVICE:${PN} += "id-button-pressed.service"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT', 'ID_BUTTON_SERVICE')}"