Jayanth Othayoth | 84bf731 | 2024-01-01 06:43:03 -0600 | [diff] [blame] | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
| 2 | |
| 3 | OBMC_CONSOLE_HOST_TTY = "ttyS0" |
Brad Bishop | c7d1cd9 | 2020-09-09 09:57:07 -0400 | [diff] [blame] | 4 | |
Konstantin Aladyshev | 2de8c60 | 2021-09-01 11:34:44 +0300 | [diff] [blame] | 5 | SRC_URI:remove = "file://${BPN}.conf" |
Jayanth Othayoth | 84bf731 | 2024-01-01 06:43:03 -0600 | [diff] [blame] | 6 | |
| 7 | SRC_URI:append = "\ |
| 8 | file://server.ttyS0.conf \ |
| 9 | file://server.ttyVUART0.conf \ |
| 10 | file://client.2200.conf \ |
| 11 | file://client.2201.conf \ |
| 12 | " |
Brad Bishop | c7d1cd9 | 2020-09-09 09:57:07 -0400 | [diff] [blame] | 13 | |
Konstantin Aladyshev | 2de8c60 | 2021-09-01 11:34:44 +0300 | [diff] [blame] | 14 | do_install:append() { |
Brad Bishop | c7d1cd9 | 2020-09-09 09:57:07 -0400 | [diff] [blame] | 15 | # Remove upstream-provided configuration |
| 16 | rm -rf ${D}${sysconfdir}/${BPN} |
| 17 | |
| 18 | # Install the server configuration |
| 19 | install -m 0755 -d ${D}${sysconfdir}/${BPN} |
| 20 | install -m 0644 ${WORKDIR}/*.conf ${D}${sysconfdir}/${BPN}/ |
Brad Bishop | c7d1cd9 | 2020-09-09 09:57:07 -0400 | [diff] [blame] | 21 | } |
Jayanth Othayoth | 84bf731 | 2024-01-01 06:43:03 -0600 | [diff] [blame] | 22 | |
| 23 | EXTRA_OECONF:append = " --enable-concurrent-servers" |
| 24 | |
| 25 | SYSTEMD_SERVICE_${PN}:remove = "obmc-console-ssh.socket" |
| 26 | |
| 27 | SYSTEMD_SERVICE_${PN}:append = " obmc-console-ssh@2200.service \ |
| 28 | obmc-console-ssh@2201.service \ |
| 29 | " |
| 30 | |
| 31 | REGISTERED_SERVICES_${PN}:append = " obmc_console_host0:tcp:2200: \ |
| 32 | obmc_console_host1:tcp:2201: \ |
| 33 | " |
| 34 | |
| 35 | FILES_${PN}:remove = "${systemd_system_unitdir}/obmc-console-ssh@.service.d/use-socket.conf" |