blob: ae8b4dcacf72b47becbdff53d82d19c0c37147ae [file] [log] [blame]
Jayanth Othayoth84bf7312024-01-01 06:43:03 -06001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2
3OBMC_CONSOLE_HOST_TTY = "ttyS0"
Brad Bishopc7d1cd92020-09-09 09:57:07 -04004
Konstantin Aladyshev2de8c602021-09-01 11:34:44 +03005SRC_URI:remove = "file://${BPN}.conf"
Jayanth Othayoth84bf7312024-01-01 06:43:03 -06006
7SRC_URI:append = "\
8 file://server.ttyS0.conf \
9 file://server.ttyVUART0.conf \
10 file://client.2200.conf \
11 file://client.2201.conf \
12"
Brad Bishopc7d1cd92020-09-09 09:57:07 -040013
Konstantin Aladyshev2de8c602021-09-01 11:34:44 +030014do_install:append() {
Brad Bishopc7d1cd92020-09-09 09:57:07 -040015 # Remove upstream-provided configuration
16 rm -rf ${D}${sysconfdir}/${BPN}
17
18 # Install the server configuration
19 install -m 0755 -d ${D}${sysconfdir}/${BPN}
20 install -m 0644 ${WORKDIR}/*.conf ${D}${sysconfdir}/${BPN}/
Brad Bishopc7d1cd92020-09-09 09:57:07 -040021}
Jayanth Othayoth84bf7312024-01-01 06:43:03 -060022
23EXTRA_OECONF:append = " --enable-concurrent-servers"
24
25SYSTEMD_SERVICE_${PN}:remove = "obmc-console-ssh.socket"
26
27SYSTEMD_SERVICE_${PN}:append = " obmc-console-ssh@2200.service \
28 obmc-console-ssh@2201.service \
29"
30
31REGISTERED_SERVICES_${PN}:append = " obmc_console_host0:tcp:2200: \
32 obmc_console_host1:tcp:2201: \
33"
34
35FILES_${PN}:remove = "${systemd_system_unitdir}/obmc-console-ssh@.service.d/use-socket.conf"