Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "A fully featured modbus protocol stack in python" |
| 2 | HOMEPAGE = "https://github.com/riptideio/pymodbus/" |
| 3 | LICENSE = "BSD-3-Clause" |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=eba8057aa82c058d2042b4b0a0e9cc63" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 5 | |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 6 | SRC_URI[sha256sum] = "c4d556a0954d00a9e1c8f1d0de03f41c4800336e6d785e820f2917eeb4ee7736" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 7 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 8 | inherit pypi python_setuptools_build_meta |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 9 | |
| 10 | PACKAGECONFIG ??= "" |
| 11 | PACKAGECONFIG[repl] = ",,,python3-aiohttp python3-click python3-prompt-toolkit python3-pygments python3-pyserial-asyncio" |
| 12 | PACKAGECONFIG[asyncio] = ",,,python3-pyserial-asyncio" |
| 13 | PACKAGECONFIG[tornado] = ",,,python3-tornado" |
| 14 | PACKAGECONFIG[twisted] = ",,,python3-twisted-conch" |
| 15 | PACKAGECONFIG[redis] = ",,,python3-redis" |
| 16 | PACKAGECONFIG[sql] = ",,,python3-sqlalchemy" |
| 17 | |
| 18 | RDEPENDS:${PN} += " \ |
| 19 | python3-asyncio \ |
| 20 | python3-core \ |
| 21 | python3-io \ |
| 22 | python3-json \ |
| 23 | python3-logging \ |
| 24 | python3-math \ |
| 25 | python3-netserver \ |
| 26 | " |
| 27 | |
| 28 | RDEPENDS:${PN} += " \ |
| 29 | python3-pyserial \ |
| 30 | python3-six \ |
| 31 | " |