blob: 5cd20c5b1ccd36d734e5a06fb13188a60a5018f8 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Bitwise terminal calculator"
2DESCRIPTION = "Bitwise is multi base interactive calculator \
3supporting dynamic base conversion and bit manipulation.\
4It's a handy tool for low level hackers, \
5kernel developers and device drivers developers."
6
7HOMEPAGE = "https://github.com/mellowcandle/bitwise"
8SECTION = "console/utils"
9
Andrew Geissler9aee5002022-03-30 16:27:02 +000010LICENSE = "GPL-3.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +000011LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
12
13SRC_URI = "https://github.com/mellowcandle/bitwise/releases/download/v${PV}/bitwise-v${PV}.tar.gz \
14 file://0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050015 file://run-ptest \
16 file://ptest.out.expected \
Andrew Geissler595f6302022-01-24 19:11:47 +000017 "
Patrick Williams2a254922023-08-11 09:48:11 -050018SRC_URI[sha256sum] = "806271fa5bf31de0600315e8720004a8f529954480e991ca84a9868dc1cae97e"
Andrew Geissler595f6302022-01-24 19:11:47 +000019
20UPSTREAM_CHECK_URI = "https://github.com/mellowcandle/bitwise/releases"
21
22S = "${WORKDIR}/${BPN}-v${PV}"
23
24DEPENDS = "ncurses readline"
25
Patrick Williams8e7b46e2023-05-01 14:19:06 -050026inherit autotools ptest
27
28do_install_ptest() {
29 install -d ${D}${PTEST_PATH}
30 install -m 0644 ${WORKDIR}/ptest.out.expected ${D}${PTEST_PATH}/ptest.out.expected
31}
32