Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Bitwise terminal calculator" |
| 2 | DESCRIPTION = "Bitwise is multi base interactive calculator \ |
| 3 | supporting dynamic base conversion and bit manipulation.\ |
| 4 | It's a handy tool for low level hackers, \ |
| 5 | kernel developers and device drivers developers." |
| 6 | |
| 7 | HOMEPAGE = "https://github.com/mellowcandle/bitwise" |
| 8 | SECTION = "console/utils" |
| 9 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 10 | LICENSE = "GPL-3.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464" |
| 12 | |
| 13 | SRC_URI = "https://github.com/mellowcandle/bitwise/releases/download/v${PV}/bitwise-v${PV}.tar.gz \ |
| 14 | file://0001-makefile.am-Fix-build-when-build-dir-is-not-same-as-.patch \ |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 15 | file://run-ptest \ |
| 16 | file://ptest.out.expected \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 17 | " |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 18 | SRC_URI[sha256sum] = "806271fa5bf31de0600315e8720004a8f529954480e991ca84a9868dc1cae97e" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 19 | |
| 20 | UPSTREAM_CHECK_URI = "https://github.com/mellowcandle/bitwise/releases" |
| 21 | |
| 22 | S = "${WORKDIR}/${BPN}-v${PV}" |
| 23 | |
| 24 | DEPENDS = "ncurses readline" |
| 25 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 26 | inherit autotools ptest |
| 27 | |
| 28 | do_install_ptest() { |
| 29 | install -d ${D}${PTEST_PATH} |
| 30 | install -m 0644 ${WORKDIR}/ptest.out.expected ${D}${PTEST_PATH}/ptest.out.expected |
| 31 | } |
| 32 | |