Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Generates traces of I/O traffic on block devices" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "blktrace is a block layer IO tracing mechanism which provides \ |
| 3 | detailed information about request queue operations up to user space. There \ |
| 4 | are three major components: a kernel component, a utility to record the i/o \ |
| 5 | trace information for the kernel to user space, and utilities to analyse and \ |
| 6 | view the trace information." |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 7 | HOMEPAGE = "http://brick.kernel.dk/snaps/" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 8 | LICENSE = "GPLv2" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" |
| 10 | |
| 11 | DEPENDS = "libaio" |
| 12 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 13 | SRCREV = "cca113f2fe0759b91fd6a0e10fdcda2c28f18a7e" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | PV = "1.2.0+git${SRCPV}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 16 | |
| 17 | SRC_URI = "git://git.kernel.dk/blktrace.git \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 18 | file://ldflags.patch \ |
Brad Bishop | bba38f3 | 2018-08-23 16:11:46 +0800 | [diff] [blame] | 19 | file://CVE-2018-10689.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | file://make-btt-scripts-python3-ready.patch \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 21 | " |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | EXTRA_OEMAKE = "\ |
| 26 | 'CC=${CC}' \ |
| 27 | 'CFLAGS=${CFLAGS}' \ |
| 28 | 'LDFLAGS=${LDFLAGS}' \ |
| 29 | " |
| 30 | |
| 31 | # There are a few parallel issues: |
| 32 | # 1) ../rbtree.o: error adding symbols: Invalid operation |
| 33 | # collect2: error: ld returned 1 exit status |
| 34 | # Makefile:42: recipe for target 'btt' failed |
| 35 | # 2) git/blkiomon.c:216: undefined reference to `rb_insert_color' |
| 36 | # collect2: error: ld returned 1 exit status |
| 37 | # Makefile:27: recipe for target 'blkparse' failed |
| 38 | # 3) ld: rbtree.o: invalid string offset 128 >= 125 for section `.strtab' |
| 39 | # 4) btreplay.o: file not recognized: File truncated |
| 40 | # collect2: error: ld returned 1 exit status |
| 41 | # btreplay/btreplay.c:47:18: fatal error: list.h: No such file or directory |
| 42 | PARALLEL_MAKE = "" |
| 43 | |
| 44 | do_install() { |
| 45 | oe_runmake ARCH="${ARCH}" prefix=${prefix} \ |
| 46 | mandir=${mandir} DESTDIR=${D} install |
| 47 | } |
| 48 | |