Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Yet Another Flash File System" |
| 2 | DESCRIPTION = "Tools for managing 'yaffs2' file systems." |
| 3 | |
| 4 | SECTION = "base" |
| 5 | HOMEPAGE = "http://www.yaffs.net" |
| 6 | |
| 7 | LICENSE = "GPLv2" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://utils/mkyaffs2image.c;beginline=11;endline=13;md5=5f5464f9b3e981ca574e65b00e438561 \ |
| 9 | file://utils/mkyaffsimage.c;beginline=10;endline=12;md5=5f5464f9b3e981ca574e65b00e438561 \ |
| 10 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | |
| 12 | PV = "0.0+git${SRCPV}" |
| 13 | |
| 14 | DEPENDS = "mtd-utils" |
| 15 | |
| 16 | # Source is the HEAD of master branch at the time of writing this recipe |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 17 | SRC_URI = "git://www.aleph1.co.uk/yaffs2;protocol=git;branch=master \ |
| 18 | file://makefile-add-ldflags.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 19 | file://0001-define-loff_t-if-not-already-defined.patch \ |
| 20 | " |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 21 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 22 | SRCREV = "3439fa4e60dd9799766b2c101f799ed9e565b632" |
| 23 | |
| 24 | UPSTREAM_CHECK_COMMITS = "1" |
| 25 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 26 | S = "${WORKDIR}/git" |
| 27 | |
| 28 | CFLAGS_append = " -I.. -DCONFIG_YAFFS_UTIL -DCONFIG_YAFFS_DEFINES_TYPES" |
| 29 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| 30 | |
| 31 | do_compile() { |
| 32 | cd utils && oe_runmake |
| 33 | } |
| 34 | |
| 35 | INSTALL_FILES = "mkyaffsimage \ |
| 36 | mkyaffs2image \ |
| 37 | " |
| 38 | do_install() { |
| 39 | install -d ${D}${sbindir}/ |
| 40 | for i in ${INSTALL_FILES}; do |
| 41 | install -m 0755 utils/$i ${D}${sbindir}/ |
| 42 | done |
| 43 | } |
| 44 | |
| 45 | BBCLASSEXTEND = "native" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 46 | |
| 47 | # Fixed make clean error: |
| 48 | #make -C /lib/modules/4.4.0-112-generic/build M=<snip> |
| 49 | #make: *** /lib/modules/4.4.0-112-generic/build: No such file or directory. Stop. |
| 50 | #make: *** [clean] Error 2 |
| 51 | CLEANBROKEN = "1" |