blob: 51dc44cc4d154003c85886b18eb480b33125050a [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "library to access web services that claim to be "RESTful""
2HOMEPAGE = "https://wiki.gnome.org/Projects/Librest"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
5
6DEPENDS = " \
7 gi-docgen \
8 gi-docgen-native \
9 glib-2.0 \
10 glib-2.0-native \
11 json-glib \
12 libsoup-2.4 \
13 libxml2-native \
14"
15
Patrick Williamsac13d5f2023-11-24 18:59:46 -060016GNOMEBASEBUILDCLASS = "autotools"
Andrew Geissler517393d2023-01-13 08:55:19 -060017inherit gnomebase gobject-introspection vala pkgconfig
18
19GNOMEBN = "rest"
20
21SRC_URI[archive.sha256sum] = "0513aad38e5d3cedd4ae3c551634e3be1b9baaa79775e53b2dba9456f15b01c9"
22
23S = "${WORKDIR}/${GNOMEBN}-${PV}"
24# * gnome environment requires libsoup build with in gnome PACKAGECONFIG
25# * libsoup-gnome support was removed upstream three years ago [1]
26# [1] https://gitlab.gnome.org/GNOME/librest/commit/8f904a8e2bb38a7bf72245cdf2f1ecad17e9a720
27EXTRA_OECONF = "--without-gnome"
28
29do_configure:prepend() {
30 # rest expects introspection.m4 at custom location (see aclocal.m4).
31 cp -f ${STAGING_DIR_TARGET}/${datadir}/aclocal/introspection.m4 ${S}/build
32}
33
34do_compile:prepend() {
35 export GIR_EXTRA_LIBS_PATH="${B}/rest/.libs"
36}